POJ2562 UVA10035 ZOJ1874 Primary Arithmetic【进制+进位】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11711   Accepted: 4289

Description

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.

Source


问题链接POJ2562 UVA10035 ZOJ1874 Primary Arithmetic

问题简述:参见上文。

问题分析读懂题意应该没有什么问题。每个输入当作两个字符串比较简单,然后就是将其各位放到数组中,再进行各个位的相加运算,并且统计进位的次数。

程序说明:需要注意输出的没有行,有点微妙的不同。

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* POJ2562 UVA10035 ZOJ1874 Primary Arithmetic */

#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>

using namespace std;

const int BASE = 10;
const int N = 10;
int a[N], b[N];
char sa[N + 1], sb[N + 1];

int main()
{
    while(cin >> sa >> sb) {
        if(strcmp(sa,"0") == 0 && strcmp(sb,"0")== 0)
            break;

        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));

        for(int i=strlen(sa) - 1, j=0; i>=0; i--,j++)
            a[j] = sa[i] - '0';
        for(int i=strlen(sb) - 1, j=0; i>=0; i--,j++)
            b[j] = sb[i] - '0';

        int carry = 0, count = 0;
        for(int i=0; i<N;i++) {
            a[i] += b[i] + carry;
            carry = a[i] / BASE;
            if(carry)
                count++;
        }

        if(count == 0)
            printf("No carry operation.\n");
        else if(count > 1)
            printf("%d carry operations.\n", count);
        else
            printf("%d carry operation.\n", count);
    }

    return 0;
}





posted on 2017-08-30 23:18  海岛Blog  阅读(162)  评论(0编辑  收藏  举报

导航