Bzoj 1086: [SCOI2005]王室联邦

1086: [SCOI2005]王室联邦

Time Limit: 10 Sec  Memory Limit: 162 MBSec  Special Judge
Submit: 1900  Solved: 1160
[Submit][Status][Discuss]

Description

  “余”人国的国王想重新编制他的国家。他想把他的国家划分成若干个省,每个省都由他们王室联邦的一个成
员来管理。他的国家有n个城市,编号为1..n。一些城市之间有道路相连,任意两个不同的城市之间有且仅有一条
直接或间接的道路。为了防止管理太过分散,每个省至少要有B个城市,为了能有效的管理,每个省最多只有3B个
城市。每个省必须有一个省会,这个省会可以位于省内,也可以在该省外。但是该省的任意一个城市到达省会所经
过的道路上的城市(除了最后一个城市,即该省省会)都必须属于该省。一个城市可以作为多个省的省会。聪明的
你快帮帮这个国王吧!

Input

  第一行包含两个数N,B(1<=N<=1000, 1 <= B <= N)。接下来N-1行,每行描述一条边,包含两个数,即这
条边连接的两个城市的编号。

Output

  如果无法满足国王的要求,输出0。否则输出数K,表示你给出的划分方案中省的个数,编号为1..K。第二行输
出N个数,第I个数表示编号为I的城市属于的省的编号,第三行输出K个数,表示这K个省的省会的城市编号,如果
有多种方案,你可以输出任意一种。

Sample Input

8 2
1 2
2 3
1 8
8 7
8 6
4 6
6 5

Sample Output

3
2 1 1 3 3 3 3 2
2 1 8

HINT

Source

非常简单的树分块,为了学莫队上树专门学学树分块

慕名来做这个题

#include<iostream>
#include<cstdio>
using namespace std;
#define maxn 1010
int n,B,cnt,head[maxn<<1],num;
typedef int exint[maxn];
exint sz,belong,cap;
bool vis[maxn];
struct node{
    int to,pre;
}e[maxn<<1];
void Insert(int from,int to){
    e[++num].to=to;
    e[num].pre=head[from];
    head[from]=num;
}
void Cola(int pre,int now){
    for(int i=head[now];i;i=e[i].pre){
        int to=e[i].to;
        if(to==pre||vis[to]==0||belong[to])continue;
        belong[to]=cnt;
        Cola(now,to);
    }
}
void dfs(int pre,int now){
    vis[now]=1;
    for(int i=head[now];i;i=e[i].pre){
        int to=e[i].to;
        if(to==pre)continue;
        dfs(now,to);
        sz[now]+=sz[to];
        if(sz[now]>=B){
            cnt++;
            Cola(pre,now);
            cap[cnt]=now;
            sz[now]=0;
        }
    }sz[now]++;
}
int main(){
    freopen("Cola.txt","r",stdin);
    scanf("%d%d",&n,&B);
    int a,b;
    for(int i=1;i<n;i++){
        scanf("%d%d",&a,&b);
        Insert(a,b);Insert(b,a);
    }
    dfs(0,1);
    printf("%d\n",cnt);
    for(int i=1;i<=n;i++){
        printf("%d ",belong[i]>0?belong[i]:cnt);
    }printf("\n");
    for(int i=1;i<=cnt;i++){
        printf("%d ",cap[i]);
    }
}

 

posted @ 2017-06-07 08:12  Echo宝贝儿  阅读(143)  评论(0编辑  收藏  举报