HDU 1498 50 years, 50 colors

Problem Description:
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

 
Input:
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 
Output:
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 
Sample Input:
1 1
1
 
2 1
 
1 1
 
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0
 
Sample Output:
-1
1
2
1 2 3 4 5
-1

 题意:有n行n列的不同颜色气球,颜色由数字表示(1~50),现在每次只能摧毁同一行或者同一列的相同颜色的气球,问k次摧毁后哪几种颜色的气球未被摧毁完

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 110
using namespace std;
int G[N][N], vis[N], use[N];
int n;
int Find(int u, int col) //匈牙利算法
{
    int i;
    for (i = 1; i <= n; i++)
    {
        if (!vis[i] && G[u][i] == col)
        {
            vis[i] = 1;
            if (!use[i] || Find(use[i], col))
            {
                use[i] = u;
                return 1;
            }
        }
    }
    return 0;
}
int main ()
{
    int kk, i, j, flag, k, ans, cou[N], s[N];
    while (scanf("%d%d", &n, &kk), n+kk)
    {
        memset(G, 0, sizeof(G));
        memset(cou, 0, sizeof(cou));
        k = flag = 0;
        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= n; j++)
            {
                scanf("%d", &G[i][j]);
                cou[G[i][j]] = 1; //记录该种颜色出现过
            }
        }
        for (i = 1; i <= 50; i++)
        {
            ans = 0;
            memset(use, 0, sizeof(use));
            if (cou[i])
            {
                for (j = 1; j <= n; j++)
                {
                    memset(vis, 0, sizeof(vis));
                    if (Find(j, i)) ans++; //查找图中是i颜色的最大匹配
                }
                if (ans > kk) //如果最大匹配比可以摧毁的次数大,那么不能被摧毁完
                {
                    s[k++] = i;
                    flag = 1;
                }
            }
        }
        if (flag == 0) printf("-1\n");
        else
        {
            printf("%d", s[0]);
            for (i = 1; i < k; i++)
                printf(" %d", s[i]);
            printf("\n");
        }
    }
    return 0;
}

 

posted @ 2015-08-11 10:22  搁浅の记忆  阅读(150)  评论(0编辑  收藏  举报