SDUT_2118 数据结构实验之链表三:链表的逆置

点击打开链接

数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Example Input

12 56 4 6 55 15 33 62 -1

Example Output

62 33 15 55 6 4 56 12

Hint

不得使用数组。

Author

#include <iostream>
using namespace std;
struct node
{
	int num;
	node *next;
};
int main()
{
	node *head,*p;
	head=new node;
	head->next=NULL;
	p=new node;
	cin>>p->num;
	while(p->num!=-1)
	{
		p->next=head->next;//本题的链表的创建相当于在在*p之后插入节点,在这儿特殊的是*P相当于head节点(即在head节点后插入节点,又保证有头节点)
		head->next=p;
		p=new node;
		cin>>p->num;
	}
	p->next=NULL;
	head=head->next;
	while(head->next!=NULL)
	{
			cout<<head->num<<' ';
		head=head->next;
	}
	cout<<head->num<<endl;
	return 0;
}





/***************************************************
User name: YT1658506207邵雪源
Result: Accepted
Take time: 0ms
Take Memory: 256KB
Submit time: 2017-07-31 12:41:20
****************************************************/


posted @ 2017-09-13 11:00  衣带渐宽、为伊憔悴  阅读(148)  评论(0编辑  收藏  举报