CentOS 伪装安装TSA for DB2

DB2 HADR需要额外安装TSA,正常情况下CentOS无法通过安装前验证。会报一个说发行版不支持的错误。

可以通过伪装成RHEL的方式使得正常安装。

修改方式如下 修改/etc/system-release文件将其内容改为

Red Hat Enterprise Linux Server release 6.7 (Final)

另外,在x86_64架构下安装可能会报一个缺少 compat-libstdc++-33 (i686)的错误 可以用如下方法解决

wget ftp://mirror.switch.ch/pool/4/mirror/scientificlinux/6.4/i386/os/Packages/compat-libstdc++-33-3.2.3-69.el6.i686.rpm

yum --disablerepo=\* install -y compat-libstdc++-33-3.2.3-69.el6.i686.rpm

报缺libstdc++.so.6的错误,可以如下解决

wget http://mirror.centos.org/centos/6/os/i386/Packages/libstdc++-4.4.7-16.el6.i686.rpm

rpm -ivh libstdc++-4.4.7-16.el6.i686.rpm

报libpam.so.* 执行

echo 'multilib_policy=all' >> /etc/yum.conf 

yum install -y pam-1.1.1-20.el6.i686

  

  

 

posted @ 2016-01-20 08:21 Swizard 阅读(...) 评论(...) 编辑 收藏