poj1144 求不同割点的个数

Network
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11914   Accepted: 5519

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2
 
题意:
有n个点,每个点之间都有相连的边。问图中不同的割点有几个。(其实应该是这张图有割点 ,但是割点不是唯一的)
 
思路:
tarjan方法,如果low[t] >= dfn[[rt],说明当前点rt是割点。要注意根节点的判断。
/*
 * Author:  sweat123
 * Created Time:  2016/6/20 21:01:10
 * File Name: main.cpp
 */
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<time.h>
#include<cstring>
#include<iostream>
#include<algorithm>
#define INF 1<<30
#define MOD 1000000007
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define pi acos(-1.0)
using namespace std;
const int MAXN = 150;
struct node{
    int to;
    int next;
}edge[MAXN*MAXN];
int pre[MAXN],vis[MAXN],ind,n,ans;
int dfn[MAXN],low[MAXN];
void add(int x,int y){
    edge[ind].to = y;
    edge[ind].next = pre[x];
    pre[x] = ind ++;
}
void dfs(int rt,int k){
    dfn[rt] = k;
    low[rt] = k;
    for(int i = pre[rt]; i != -1; i = edge[i].next){
        int t = edge[i].to;
        if(!dfn[t]){
            dfs(t,k+1);
            low[rt] = min(low[t],low[rt]);
            if(low[t] >= dfn[rt]){
                vis[rt] ++;
            }
        }
        else {
            low[rt] = min(low[rt],dfn[t]);
        }
    }
}
int main(){
    while(~scanf("%d",&n)){
        if(!n)break;
        ind = 0;
        memset(pre,-1,sizeof(pre));
        while(1){
            int x,y;
            scanf("%d",&x);
            if(!x)break;
            while(1){
                scanf("%d",&y);
                add(x,y);
                add(y,x);
                if(getchar() == '\n')break;
            }
        }
        memset(vis,0,sizeof(vis));
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));
        dfs(1,1);
        int ans = 0;
        vis[1] --;
        for(int i = 1; i <= n; i++){
            if(vis[i] > 0)ans += 1;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2016-06-20 21:28  sweat123  阅读(682)  评论(0编辑  收藏  举报