转自:https://blog.csdn.net/ausboyue/article/details/85405593

有时候我们开启或重启Nginx时会报如下错误:

Nginx [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)

原因是端口号80被其它程序或文件占用了,那么就干掉这个程序吧:
root用户下:

fuser -k 80/tcp
1
非root用户下:

sudo fuser -k 80/tcp
1
然后开启或重启Nginx即可。

fuser命令可以干掉绝大数占用端口的程序或文件,望学之。