1220 数字三角形

 时间限制: 1 s

 空间限制: 128000 KB
 题目等级 : 黄金 Gold
 
 
题目描述 Description

如图所示的数字三角形,从顶部出发,在每一结点可以选择向左走或得向右走,一直走到底层,要求找出一条路径,使路径上的值最大。

输入描述 Input Description

第一行是数塔层数N(1<=N<=100)。

第二行起,按数塔图形,有一个或多个的整数,表示该层节点的值,共有N行。

输出描述 Output Description

输出最大值。

样例输入 Sample Input

5

13

11 8

12 7 26

6 14 15 8

12 7 13 24 11

样例输出 Sample Output

86

数据范围及提示 Data Size & Hint
数字三角形
代码:

#include<cstdio>
#include<algorithm>
using namespace std;
bool d;
int b[101][101],n,tot;
int main(){
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++){
for(j=1;j<=i;j++){
scanf("%d",&b[i][j]);
}
}
for(i=n-1;i>=1;i--)
for(j=1;j<=i;j++)
b[i][j]+=max(b[i+1][j],b[i+1][j+1]);
printf("%d\n",b[1][1]);
return 0;
}

思路: 从倒数第二行向上开始推,最后输出f[1][1];(与“数塔”一题差不多)

posted @ 2016-08-11 20:06  浮华的终成空  阅读(119)  评论(0编辑  收藏  举报

Contact with me