BZOJ_2527_[Poi2011]Meteors_整体二分

BZOJ_2527_[Poi2011]Meteors_整体二分

Description

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study.
The member states of BIU have already placed space stations close to the planet's orbit. The stations' goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states.
Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come.
Byteotian Interstellar Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。
这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。
输入:
第一行是两个数N,M。
第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。
第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,...,Ri,否则就是Ri,Ri+1,...,m-1,m,1,...,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出:
N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。
数据范围:
数据范围: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into.
In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors.
In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather.
In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9).
In tests worth at least 20% of the points it additionally holds that .

Output

 
Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

Sample Input

3 5
1 3 2 1 3
10 5 7
3
4 2 4
1 3 1
3 5 2

Sample Output

3
NIE
1


 整体二分。

solve(b,e,l,r)表示处理b到e的询问,答案在l到r区间内。

二分mid,把l到mid之间的陨石加进去。

用树状数组维护区间加单点求和。

如果答案在左边就往左走,否则减去左边的贡献往右走。

 

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define N 300050
int n,m,c[N],ans[N],head[N],to[N],nxt[N],cnt,k;
inline void add(int u,int v) {
    to[++cnt]=v; nxt[cnt]=head[u]; head[u]=cnt;
}
struct A {
    int id,v;
}q[N],t[N];
struct P {
    int l,r,v;
}a[N];
void fix(int x,int v){for(;x<=m;x+=x&(-x)) c[x]+=v;}
int inq(int x){int re=0;for(;x;x-=x&(-x)) re+=c[x]; return re;}
void solve(int b,int e,int l,int r) {
    if(b>e) return ;
    int i,mid=(l+r)>>1,lp=b,rp=e,j;
    if(l==r) {
        for(i=b;i<=e;i++) ans[q[i].id]=l;
        return ;
    }
    for(i=l;i<=mid;i++) {
        if(a[i].l<=a[i].r) {
            fix(a[i].l,a[i].v); fix(a[i].r+1,-a[i].v);
        }else {
            fix(1,a[i].v); fix(a[i].r+1,-a[i].v);
            fix(a[i].l,a[i].v);
        }
    }
    for(i=b;i<=e;i++) {
        int sizls=0;
        for(j=head[q[i].id];j;j=nxt[j]) {
            int pos=to[j]-n;
            sizls+=inq(pos);
            if(sizls>=q[i].v) break;
        }
        if(sizls>=q[i].v||sizls<0) t[lp++]=q[i];
        else q[i].v-=sizls,t[rp--]=q[i];
    }
    for(i=b;i<=e;i++) q[i]=t[i];
    for(i=l;i<=mid;i++) {
        if(a[i].l<=a[i].r) {
            fix(a[i].l,-a[i].v); fix(a[i].r+1,a[i].v);
        }else {
            fix(1,-a[i].v); fix(a[i].r+1,a[i].v);
            fix(a[i].l,-a[i].v);
        }
    }
    solve(b,rp,l,mid);
    solve(lp,e,mid+1,r);
}
int main() {
    scanf("%d%d",&n,&m);
    int i,x;
    for(i=1;i<=m;i++) {
        scanf("%d",&x);
        add(x,i+n);
    }
    for(i=1;i<=n;i++) {
        scanf("%d",&q[i].v); q[i].id=i;
    }
    scanf("%d",&k);
    for(i=1;i<=k;i++) {
        scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].v);
    }
    solve(1,n,1,k+1);
    for(i=1;i<=n;i++) {
        if(ans[i]<=k) printf("%d\n",ans[i]);
        else puts("NIE");
    }
}

 

posted @ 2018-04-28 19:04  fcwww  阅读(212)  评论(0编辑  收藏  举报