源码编译安装keepalived

首先到官网下载需要的包:http://www.keepalived.org/download.html

 
[root@localhost local]# tar -zxvf /tmp/keepalived-1.3.5.tar.gz

[root@localhost local]# cd keepalived-1.3.5/

[root@localhost keepalived-1.3.5]# ./configure --prefix=/usr/local/keepalived

然后系统出现警告:

*** WARNING - this build will not support IPVS with IPv6. Please install libnl/libnl-3 dev libraries to support IPv6 with IPVS.

[root@localhost keepalived-1.3.5]# yum -y install libnl libnl-devel

安装完以后重新执行configure

这次出现错误:

configure: error: libnfnetlink headers missing

[root@localhost keepalived-1.3.5]# yum install -y libnfnetlink-devel

重新执行configure

 

现在进行编译:

[root@localhost keepalived-1.3.5]# make && make install

到这里就安装完成了!

 

posted @ 2017-04-12 01:24  1011110  阅读(11980)  评论(0编辑  收藏  举报