UVA 10131题解

第一次写动态规划的代码,整了一天,终于AC。

题目:

 

Question 1: Is Bigger Smarter?

The Problem

Some people think that the bigger an elephant is, the smarter it is. To disprove this, you want to take the data on a collection of elephants and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the IQ's are decreasing.

The input will consist of data for a bunch of elephants, one elephant per line, terminated by the end-of-file. The data for a particular elephant will consist of a pair of integers: the first representing its size in kilograms and the second representing its IQ in hundredths of IQ points. Both integers are between 1 and 10000. The data will contain information for at most 1000 elephants. Two elephants may have the same weight, the same IQ, or even the same weight and IQ.

Say that the numbers on the i-th data line are W[i] and S[i]. Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing an elephant). If these n integers are a[1], a[2],..., a[n] then it must be the case that

   W[a[1]] < W[a[2]] < ... < W[a[n]]
and
   S[a[1]] > S[a[2]] > ... > S[a[n]]
In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and IQs must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7
 

题解:

两种解法:

 

步骤:1. 对大象按照重量进行递增排序,相同体重的按照IQ递减排序,得到大象序列A

           2. 求A进行最长递减子序列,动态规划法。

设f(i)表示L中以ai为末元素的最长递增子序列的长度。则有如下的递推方程:

这个递推方程的意思是,在求以ai为末元素的最长递增子序列时,找到所有序号在L前面且小于ai的元素aj,即j<i且aj<ai。如果这样的元素存在,那么对所有aj,都有一个以aj为末元素的最长递增子序列的长度f(j),把其中最大的f(j)选出来,那么f(i)就等于最大的f(j)加上1,即以ai为末元素的最长递增子序列,等于以使f(j)最大的那个aj为末元素的递增子序列最末再加上ai;如果这样的元素不存在,那么ai自身构成一个长度为1的以ai为末元素的递增子序列。

#include <stdio.h>
#include <stdlib.h>
typedef struct {
    int index;
    int w;
    int iq;
} Niu;
int comp(const void * a, const void * b)
{
    int v=((Niu *)a)->w-((Niu *)b)->w;
     if( v== 0)
     {
        return ((Niu *)b)->iq-((Niu *)a)->iq;
     }else return v;
}

Niu ns[1002];
int f[1002]; //以ns[i]为末尾的序列长度
int mi[1002];
int out[1002];
int main()
{
    int c=0,c2,n,m, i,j,t1,t2;

    while(scanf("%d %d",&t1, &t2)==2){
        ns[c].w=t1;
        ns[c].iq=t2;
        ns[c].index=c+1;
        c++;
    }
    qsort(ns,c,sizeof(Niu),comp); //排序,重量递增排序,如果重量相同,iq递减排序


    f[0]=1; //初始化
    //dp
    for(i=0; i<c; i++) //
    {
        int max=0;
        int midx=-1;
        for(j=0; j<i;j++) //找0到i-1见f(i)最长并且
        {
            if(ns[i].iq<ns[j].iq &&ns[i].w!=ns[j].w && max<f[j]){
                max=f[j];
                midx=j;
            }
        }
        f[i]=max+1;
        mi[i]=midx;
    }
   int max=-1;
   int midx;
   for(i=0; i<c; i++){

        if(f[i]>max){max=f[i];midx= i;}
   }
   printf("%d\n",max);
    int cxxx=0;
    while(1) //输出
    {
        out[cxxx]= ns[midx].index;
        cxxx++;
        midx=mi[midx];
        if(midx==-1)break;
    }
    for(i=cxxx; i>0;i--)
    {
        printf("%d\n", out[i-1]);
    }

    return 0;
}

 

对于这个问题,还有另一个解法,是将最长递减子序列转变为最长公共子序列问题。

不过很复杂,导致一直WE,我的错误代码如下:

#include <stdio.h>
#include <stdlib.h>
typedef struct {
    int index;
    int w;
    int iq;
} Niu;
int comp(const void * a, const void * b)
{
    int v=((Niu *)a)->w-((Niu *)b)->w;
     if( v== 0)
     {
        return ((Niu *)b)->iq-((Niu *)a)->iq;
     }else return v;
}
int comp2(const void * a, const void * b)
{
    int v=((Niu *)b)->iq-((Niu *)a)->iq;
    if(v==0){
        return ((Niu *)a)->w-((Niu *)b)->w;
    }else
    return v;
}
Niu ns[1001];
Niu ns2[1001];
Niu tmp[1002];
int cm[1002][1002];
int tag[1002][1002]; // 1,-1,-2
int result[1002];
int resultSize;
void dp(int n,int m) //c表示大小
{
    int i,j,k;
    k=0;
    for(i=0; i<n; i++)
    {
        for(j=0;j<m; ++j)
        {
            if(ns[i].iq==ns2[j].iq)
            {
                cm[i+1][j+1]=cm[i][j]+ 1;
                tag[i+1][j+1] = 1;
            }else if(cm[i][j+1]>=cm[i+1][j]){
                cm[i+1][j+1]=cm[i][j+1];
                tag[i+1][j+1] = -1;
            }else{
                cm[i+1][j+1]=cm[i+1][j];
                tag[i+1][j+1] = -2;
            }
        }
    }
}
void printLCS(int i, int j)
{
    if(i==0 || j==0)
        return;
    if(tag[i][j]==1){
        printLCS(i-1,j-1);
        result[resultSize]=ns[i-1].index;
        resultSize++;
    }else if(tag[i][j]==-1)
    {
        printLCS(i-1,j);
    }else {
        printLCS(i,j-1);
    }
}

/*
test case 1:
1000 900
1000 800
1010 900
1010 800

test case 2:
1000 900
1000 900
1010 900
1010 800

test case 3:
100 20
110  20
120  20

test case 4:
100 20
100 20
100 20
100 20
110 19
110 20
test case 5:  the result should by
100 20
110 19
110 20

*/
int main()
{
    int c=0,c2,n,m, i,j,t1,t2;

    while(scanf("%d %d",&t1, &t2)==2){
        ns[c].w=t1;
        ns[c].iq=t2;
        ns[c].index=c+1;
        c++;
    }

    for(i=0; i<c; i++)
    {
        ns2[i] = ns[i];
    }
    qsort(ns,c,sizeof(Niu),comp);

    printf("ns:\n");
    for(i=0; i<c; i++)
    {
        printf("%d %d\n", ns[i].w,ns[i].iq);
    }

    qsort(ns2,c,sizeof(Niu),comp2);
    //要把ns2的重复iq的项去掉
    j=0;
    tmp[0]=ns2[0];
    for(i=1;i<c;i++){
        if(ns2[i].iq!=tmp[j].iq){
            ++j;
            tmp[j]=ns2[i];
        }
    }

    c2=j+1; //去重复大小
    for(i=0; i<c2; i++){
        ns2[i]=tmp[i];
    }
    printf("c2:%d\n",c2);


    dp(c,c2);
    printLCS(c,c2);

    //去重复
    //
    /*

    */
    int ss=resultSize;
    printf("size:%d\n",resultSize);
    for(i=0; i<resultSize; i++){
        printf("%d\n",result[i]);
    }
    int pre=0;
    for(i=1; i<resultSize; i++){
        if(ns[result[i]-1].w!=ns[result[pre]-1].w && ns[result[i]-1].iq!=ns[result[pre]-1].iq ){
            pre=i;
        }else{
            ss--;
            result[i]=-1;
        }
    }
    printf("ss:%d\n",ss);
    for(i=0; i<resultSize; i++){
        if(result[i]!=-1)printf("%d\n", result[i]);
    }
    return 0;
}
posted @ 2014-04-02 12:39  stonehat  阅读(486)  评论(0编辑  收藏  举报