HDU 3172 Virtual Friends(map+并查集)

Virtual Friends

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 61   Accepted Submission(s) : 28

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

Source

University of Waterloo Local Contest 2008.09
题解:
题目求得是朋友链上有多少人
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<set>
#include<map>
using namespace std;
int tot,T,n;
int num[100005],team[100005];
map<string,int >mp;
int name(char *ch)
{
    if (mp.find(ch)==mp.end())
    {
        mp[ch]=++tot;
        return tot;
    }
    else return mp[ch];
}
int findteam(int k)
{
    if (team[k]==k) return k;
     else return team[k]=findteam(team[k]);
}
int main()
{
    while(~scanf("%d",&T))
    {
    for(;T>0;T--)
    {
        scanf("%d",&n);
        tot=0; mp.clear();
        for(int i=1;i<=100000;i++)
        {
            team[i]=i;
            num[i]=1;
        }
        for(int i=1;i<=n;i++)
        {
            char str1[25],str2[25];
            scanf("%s%s",&str1,&str2);
            int id1=name(str1);
            int id2=name(str2);
            int fx=findteam(id1);
            int fy=findteam(id2);
            if (fx==fy) printf("%d\n",num[fx]);
             else
             {
                 team[fx]=fy;
                 num[fy]+=num[fx];
                 printf("%d\n",num[fy]);
             }
        }
    }
    }
    return 0;
}

 

posted on 2017-07-21 16:14  Yxter  阅读(145)  评论(0编辑  收藏  举报

导航