RIP 实验

 实验要求

1.  理解 RIP 协议的工作原理
2.  理解 RIPv1、RIPv2 的特性
3.  掌握 RIP 协议的基本配置方法
4.  掌握 RIP 自动汇总和手动汇总的方法
5.  掌握 RIP 配置默认路由的方法
6.  掌握 RIP 认证的基本配置
7.  实验工具:GNS3

实验拓扑

 

实验过程

接口配置

R1 配置

int loopback 0
ip add 10.30.31.1 255.255.255.0 secondary
ip add 10.30.32.1 255.255.255.0 secondary
ip add 10.30.33.1 255.255.255.0 secondary
ip add 10.30.30.1 255.255.255.0
int loopback 1
ip add 192.168.3.1 255.255.255.0
int fa0/0
ip add 192.168.1.1 255.255.255.0
no shutdown

 

R2 配置

int loopback 0
ip add 192.168.4.1 255.255.255.0
int fa0/0
ip add 192.168.1.2 255.255.255.0
no shutdown int fa0/1 ip add 192.168.2.1 255.255.255.0
no shutdown

R3 配置

int loopback 0
ip add 10.30.51.1 255.255.255.0 secondary
ip add 10.30.52.1 255.255.255.0 secondary
ip add 10.30.53.1 255.255.255.0 secondary
ip add 10.30.50.1 255.255.255.0
int loopback 1
ip add 192.168.5.1 255.255.255.0
int  loopback 2
ip add 211.30.188.1 255.255.255.0
int f0/1
ip add 192.168.2.2 255.255.255.0
no shutdown

 
注 1:给接口添加第二 IP 地址,通过这个命令可以给接口添加多个 IP 地址,在 Packet Tracer下没有这个命令,真实路由器中支持

 

2、在路由器中配置 RIP 协议(注,根据步骤 1 所配置的 IP 地址配置 RIP 协议)
R1 配置:
router rip
network 10.0.0.0
network 192.168.1.0
network 192.168.3.0


R2 配置:
router rip
network 192.168.1.0
network 192.168.4.0


注 2:network 用来添加网络,在 RIP 中只需添加网络号即可。

该命令的作用主要有两个:
一是声明 RIP 转发哪些网络的路由表;二是声明在路由器的哪些接口上启用 RIP 协议。

注 3:注意这里没有添加 192.168.2.0,所以接口 f0/0 不会发送和接收 RIP 报文


R3 配置:
router rip
network 10.0.0.0
network 192.168.2.0
network 192.168.5.0

注 4:这里没有添加 211.30.188.0,这是因为 211.30.188.0 连接 Internet,内部路由不能转发到外网,同时内部的网络也不需要知道外网的情况。

 

问题 1:配置后在每个路由器上查看路由表,在路由器 R1 和 R2 中能看到 192.168.5.0 吗?

答:不能。

R1

 

R2

R3

 

 

在路由器 R3 中能看到路由器 R1 和 R2 中的路由吗?

不能

 

 

问题 2:现在在路由器 R2 中添加 192.168.2.0,再查看每个路由器的路由表,看有什么变化?

R1

R2:

 

R3:

 

 

问题 3:这时在路由器 R3 中 ping 10.30.30.1 看能否 ping 通,为什么?提示:看路由表

R3中的路由表项里没有到10.30.30.0/24的记录

 
3、测试不同版本 RIP 协议之间的数据传递,在路由器 R1 中启用 RIPv2

然后在每个路由器中删除当前路由表,重新生成路由表后,查看各路由器中路由表变化。

启用 RIPv2 命令:
R1(config)#router rip
R1(config-router)#version 2

删除路由表命令:
R1#clear ip route *


问题 4:在 R1 中能否看到 R2 和 R3 中的路由?在 R2 中能否看到 R1 的路由。

R1

R2

 

4、配置手动汇总,解决“问题 3”中无法通信问题。
(1)首先,在 R2 和 R3 中也启用 RIPv2,命令参考 R1 中启用 RIPv2 命令。
(2)在每个路由器中关闭自动汇总,关闭自动汇总参考命令:
  R1(config-router)#no auto-summary
(3)在路由器 R1 ,R3的接口中配置手动汇总,参考命令:
  R1(config-if)#interface f0/0
  R1(config-if)#ip summary-address rip 10.30.30.0 255.255.192.0
  R3(config-if)#interface f0/1
  R3(config-if)#ip summary-address rip 10.30.50.0 255.255.192.0
  注 5:该命令格式为 ip summary-address rip 网络地址 子网掩码,命令的作用是在该接口上向外发送路由更新时把多个网络汇总成一个路由条目问题

 

5:此时在路由器 R3 上 ping 10.30.31.1,能否 ping 通?

 

5、在路由器 R3 上启用默认路由,让内部网络可以访问 Internet。
在路由器 R3 上配置静态默认路由
R3(config)#ip route 0.0.0.0 0.0.0.0 211.30.188.2 
在路由器 R3 中配置向其他路由器注入默认路由
R3(config)#router rip
R3(config-router)#default-information originate

 

问题 6:在 R1 和 R2 中查看路由表,有什么变化?此时在 R1 中 ping 211.67.188.1,能否 ping
通?

R1

R2

 

可以ping通

 

 


7、 在路由器 R1 和 R2 之间实现认证。
R1 中的配置命令:
R1(config)#key chain xcu
注:xcu 修改为自己的姓名拼音
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string xcu2012
注:xcu2012 修改为自己的学号
R1(config)#interface f0/0
R1(config-if)#ip rip authentication key-chain xcu
注:xcu 修改为自己的姓名拼音
R1(config-if)#ip rip authentication mode md5

问题 7:在 R1 中配置之后,删除 R1 和 R2 的当前路由表,重新生成,在 R1 中能否看到其
他路由器上的路由?

看不到

 

8、 参考 R1 的配置,在 R2 中做同样的认证配置,然后更新路由表,在 R1 中能否看到其他
路由器上的路由?注意,应在R2 对应的接口中启用认证。

 

9、 修改路由器 R3 发送出去的路由信息的度量值,参考命令如下:
创建访问控制列表 ACL,配置需要修改 metric 的路由条目
R1(config)#access-list 10 permit 192.168.5.0 0.0.0.255 注:编号 10 修改为自己的学号后两位
R1(config)#router rip
R1(config-router)#offset-list 10 out 2 f0/1
注:编号 10 修改为自己的学号后两位

问题 8:修改后查看路由器 R1 上关于 192.168.5.0 的路由,距离是多少?修改前的距离是多
少?

 

10、做完所有配置后注意保存,保存命令如下:
R1#write
或者
R1#copy running-config startup-config

 

posted @ 2017-03-12 13:27  ssooking  阅读(1760)  评论(0编辑  收藏