随笔-125  评论-1  文章-0 

rabbitMQ linux安装

1,下载 erlang (http://www.rabbitmq.com/releases/erlang/)

  wget http://www.rabbitmq.com/releases/erlang/erlang-18.2-1.el6.x86_64.rpm

2,安装 erlang

  rpm -ihv http://www.rabbitmq.com/releases/erlang/erlang-18.2-1.el6.x86_64.rpm 

3,下载 rabbitMQ server (http://www.rabbitmq.com/install-rpm.html) (根据自己的系统下载)

  

 

 4,安装 

  

    rpm --import https://www.rabbitmq.com/rabbitmq-release-signing-key.asc

    rpm -ihv rabbitmq-server-3.6.10-1.el6.noarch.rpm

  报错:

      error: Failed dependencies:

    socat is needed by rabbitmq-server-3.6.10-1.el6.noarch

      解决: 

  1. wget no-cache http://www.convirture.com/repos/definitions/rhel/6.x/convirt.repo -O /etc/yum.repos.d/convirt.repo
  2. yum makecache
  3. yum install socat
  4. 再次安装 rpm -ihv rabbitmq-server-3.6.10-1.el6.noarch.rpm

5,安装管理插件

  rabbitmq-plugins enable rabbitmq_management

6,重启 service rabbitmq-server restart

7,去浏览器访问 http://192.168.71.133:15672/   (前面是我linux的ip 后面是端口)

 

  8 ,用系统默认的guest账号  结果登录失败  因为权限的问题把, 我新建了一个用户  kevin 密码是 111111  ,然后给了超级管理员的权限 (参考http://www.cnblogs.com/spicy/p/7017586.html)

    

 

  9 , 再次登录 成功

  

 

posted on 2017-06-15 14:34 一只猪儿虫 阅读(...) 评论(...) 编辑 收藏