hello cc

MYSQL 一些问题

Posted on 2014-11-23 00:03  星际海盗  阅读(148)  评论(0)    收藏  举报

突然有一天发现mysql 无法启动,

错误的具体内容是:

121012 11:35:03 [Note] Plugin 'FEDERATED' is disabled.              
121012 11:35:03  InnoDB: Error: unable to create temporary file; errno: 2
121012 11:35:03 [ERROR] Plugin 'InnoDB' init function returned error.
121012 11:35:03 [ERROR] Plugin  'InnoDB' registration as a STORAGE ENGINE failed.
121012 11:35:03 [ERROR] Unknown/unsupported table type: INNODB
121012 11:35:03 [ERROR] Aborting

----------------------------------------------------------------------------------------
在网上找到解决方案:

1、在MY.INI文件中的 [mysqld] 中增加tmpdir 的路径, 只可惜,已经有路径,而且路径正确,所有没用

2、删除DATA目录下除数据库文件夹外的其他文件,重启mysql,问题没有解决。

其他:
第一步:

只要删除MySQL目录下的ib_logfile0和ib_logfile1两个文件
第二步:
无法启动的原因:MySQL在安装的时候不会自动初始tmpdir(临时文件目录),所以要在配置文件my.ini中添加tmpdir路径。 没用的

最后,有人重新安转了myslq并对文件做了对比,发现mysql的配置文件不一样,怀疑是病毒干的事,使用杀毒软件后发现好多病毒,

好吧,只好重装,windows真烦人,病毒太多

 

 

mysql的一些命令:

查看mysql中所有的用户以及密码

select * from mysql.user \G
查看所有存在的用户

 

 

查找特定表:

  1. SELECT distinct TABLE_NAME  
  2. FROM INFORMATION_SCHEMA.COLUMNS  
  3. WHERE TABLE_NAME LIKE '%medias%'  

 

hello man