算法分析之快排

题目描述

Quicksort is a well-known sorting algorithm developed by C. A. R.

Hoare that, on average, makes Θ(n log n) comparisons to sort n items. However, in the worst case, it makes Θ(n2) comparisons. Typically, quicksort is significantly faster in practice than other Θ(n log n) algorithms, because its inner loop can be efficiently implemented on most architectures, and in most real-world data it is possible to make design choices which minimize the possibility of requiring quadratic time.

Quicksort sorts by employing a divide and conquer strategy to divide a list into two sub-lists.

The steps are:

1. Pick an element, called a pivot, from the list.

2. Reorder the list so that all elements which are less than the pivot come before the pivot and so that all elements greater than the pivot come after it (equal values can go either way). After this partitioning, the pivot is in its final position. This is called the partition operation.

3. Recursively sort the sub-list of lesser elements and the sub-list of greater elements. The base case of the recursion are lists of size zero or one, which are always sorted. The algorithm always terminates because it puts at least one element in its final place on each iteration (the loop invariant).

 

Quicksort in action on a list of random numbers. The horizontal lines are pivot values. Write a program to sort ascending int number by QuickSort ,n less than 50000.

输入

two lows, the first low is numbers , less and equal than 50000. the second low is a set integer numbers

输出

a set integer numbers of sort ascending

样例输入复制

10
4 2 1 5 7 6 9 8 0 3

样例输出复制

0 1 2 3 4 5 6 7 8 9

#include <iostream>
using namespace std;
void Qsort(int arr[], int low, int high){
    if (high <= low) return;
    int i = low;
    int j = high + 1;
    int key = arr[low];
    while (true)
    {
        /*从左向右找比key大的值*/
        while (arr[++i] < key)
            if (i == high)
                break;
        /*从右向左找比key小的值*/
        while (arr[--j] > key)
            if (j == low)
                break;
            
        
        if (i >= j) break;
        /*交换i,j对应的值*/
        int temp = arr[i];
        arr[i] = arr[j];
        arr[j] = temp;
    }
    /*中枢值与j对应值交换*/
    int temp = arr[low];
    arr[low] = arr[j];
    arr[j] = temp;
    Qsort(arr, low, j - 1);
    Qsort(arr, j + 1, high);
}
int main()
{
    int n;
    cin>>n;
    int a[n];
    for(int i=0;i<n;i++) cin>>a[i];
    Qsort(a, 0, sizeof(a) / sizeof(a[0]) - 1);
    /*这里原文第三个参数要减1否则内存越界*/
    for(int i = 0; i < n; i++)
    {
        cout <<a[i]<<" ";
        
    }cout<<endl;
    return 0;
}

(非原创,原博客我忘了是谁的)

posted @ 2020-05-31 16:17  Admin-2000  阅读(270)  评论(0编辑  收藏  举报