hdu 5086 Revenge of Segment Tree

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 845    Accepted Submission(s): 302


Problem Description
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.
 

 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000
 

 

Output
For each test case, output the answer mod 1 000 000 007.
 

 

Sample Input
2 1 2 3 1 2 3
 

 

Sample Output
2 20
Hint
For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20. Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded. And one more little helpful hint, be careful about the overflow of int.
 

 

Source
 
 
#include<cstdio>
#include<iostream>
#define mod 1000000007
using namespace std;
__int64 a[500000];
__int64 sum;
int main()
{
    __int64 i,j,n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        sum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&a[i]);
            sum+=a[i]*(i * (n - i + 1)%mod);// 主要注意这里会超long long 所以要在内部取余
            sum%=mod;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}

  

posted @ 2014-11-03 20:52  sola94  阅读(125)  评论(0编辑  收藏  举报