奔小康赚大钱

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6026    Accepted Submission(s): 2663


Problem Description
传说在遥远的地方有一个非常富裕的村落,有一天,村长决定进行制度改革:重新分配房子。
这可是一件大事,关系到人民的住房问题啊。村里共有n间房间,刚好有n家老百姓,考虑到每家都要有房住(如果有老百姓没房子住的话,容易引起不安定因素),每家必须分配到一间房子且只能得到一间房子。
另一方面,村长和另外的村领导希望得到最大的效益,这样村里的机构才会有钱.由于老百姓都比较富裕,他们都能对每一间房子在他们的经济范围内出一定的价格,比如有3间房子,一家老百姓可以对第一间出10万,对第2间出2万,对第3间出20万.(当然是在他们的经济范围内).现在这个问题就是村领导怎样分配房子才能使收入最大.(村民即使有钱购买一间房子但不一定能买到,要看村领导分配的).
 

 

Input
输入数据包含多组测试用例,每组数据的第一行输入n,表示房子的数量(也是老百姓家的数量),接下来有n行,每行n个数表示第i个村名对第j间房出的价格(n<=300)。
 

 

Output
请对每组数据输出最大的收入值,每组的输出占一行。

 

 

Sample Input
2 100 10 15 23
 

 

Sample Output
123
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3360 2444 1281 1533 2426 
O(n^4)会超时;
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

const int N = 510;   //MAXENODES;
const int M = 510;
const int INF = 0x3f3f3f3f;

struct KM
{
    int n, m;
    int G[N][N];
    int Lx[N], Ly[N], slack[N];
    int left[N], right[N];
    bool S[N], T[N];
    void Init(int a, int b)
    {
        //this->n = n;
        //this->m = m;
        n = a; m = b;
        memset(G, 0, sizeof(G));
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                scanf("%d", &G[i][j]);
    }

    void update()
    {
        int a = INF;
        for(int i = 0; i < m; i++)
            if(!T[i])
                a = min(a, slack[i]);
        for(int i = 0; i < n; i++)
            if(S[i])
                Lx[i] -= a;
        for(int i = 0; i < m; i++)
            if(T[i])
                Ly[i] += a;
    }
    bool dfs(int u)
    {
        S[u] = true;
        for(int v = 0; v < m; v++)
        {
            if(T[v])
                continue;
            int temp = Lx[u]+Ly[v]-G[u][v];
            if(!temp)
            {
                T[v] = true;
                if(left[v]==-1 || dfs(left[v]))
                {
                    left[v] = u;
                    right[u] = v;
                    return true;
                }
            }
            else
                slack[v]=min(slack[v], temp);
        }
        return false;
    }
    int km()
    {
        memset(left, -1, sizeof(left));
        memset(right, -1, sizeof(right));
        memset(Ly, 0, sizeof(Ly));

        for(int i = 0; i < n; i++)
        {
            Lx[i] =  -INF;
            for(int j = 0; j < m; j++)
                Lx[i]=max(Lx[i], G[i][j]);
        }

        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
                slack[j] = INF;
            while(1)
            {
                memset(S, 0, sizeof(S));
                memset(T, 0, sizeof(T));
                if(dfs(i))
                    break;
                else
                    update();
            }
        }

        int ans = 0;
        for(int i = 0; i < n; i++)
        {
           // printf("%d\n", G[i][right[i]]);
            ans += G[i][right[i]];
        }
        printf("%d\n", ans);
    }
}Km;
int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        Km.Init(n, n);
        Km.km();
    }
    return 0;
}

 

 
posted on 2016-01-10 17:38  cleverbiger  阅读(187)  评论(0编辑  收藏  举报