591 - Box of Bricks

 

 Box of Bricks 

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and buildsstacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you shouldmake all stacks the same height. Then you would have a real wall.'', she retorts. After a little con-sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that allstacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimumnumber of bricks moved. Can you help?

 

 

Input 

The input consists of several data sets. Each set begins with a line containing the number n of stacksBob has built. The next line contains n numbers, the heights h i of the n stacks. You may assume $1 Ÿ\le n \leŸ 50$and $1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possibleto rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

 

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line`` The minimum number of moves is k.'', where k is the minimum number of bricks thathave to be moved in order to make all the stacks the same height.

Output a blank line after each set.

 

Sample Input 

6
5 2 4 1 7 5
0

 

Sample Output 

Set #1
The minimum number of moves is 5.
#include<stdio.h>
int main(void)
{
	int n,i,count=1;
	while(scanf("%d",&n)&&n)
	{
		int h,k=0,sum=0,a[100]={0};
		for(i=0;i<n;i++) 
		{scanf("%d",&a[i]);sum+=a[i];}
		h=sum/n;
		for(i=0;i<n;i++)
			if(a[i]>h)
				k+=a[i]-h;
		printf("Set #%d\nThe minimum number of moves is %d.\n\n",count++,k);
	}
	return 0;
}


posted @ 2013-06-21 14:13  爱生活,爱编程  阅读(220)  评论(0编辑  收藏  举报