POJ 2524 Ubiquitous Religions (幷查集)

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 23090   Accepted: 11378

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source



#include <iostream>
#include <cstdio>
using namespace std;
int f[50005],sum;
//查找x的父节点,假设f[x]==x。他的父节点就是本身。
int find (int x)
{
if(f[x]!=x)
    f[x]=find(f[x]);
    return f[x];
}       
//假设不是一个集合(父节点不同样),合并集合(将父节点改成b的父节点)。        
void make(int a,int b)
{
    int f1=find(a);
    int f2=find(b);
    if(f1!=f2)
    {
        f[f2]=f1;
        sum--;                  //宗教数减一。
    }
}
int main()
{
  int n,m,p=1,i;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
      if(n==0&&m==0) break;
      for(i=1;i<=n;i++)
        f[i]=i;
      sum=n;
      for(i=1;i<=m;i++)
      {
          int a,b;
          scanf("%d%d",&a,&b);
          make(a,b);
      }
      printf("Case %d: %d\n",p++,sum);


  }
 return 0;
}

posted on 2017-05-18 13:33  slgkaifa  阅读(191)  评论(0编辑  收藏  举报

导航