【Aizu - ALDS1_7_A】Rooted Trees(树的表达)

Rooted Trees

Descriptions:

A graph G = (VE) is a data structure where V is a finite set of vertices and E is a binary relation on V represented by a set of edges. Fig. 1 illustrates an example of a graph (or graphs).

 
Fig. 1

A free tree is a connnected, acyclic, undirected graph. A rooted tree is a free tree in which one of the vertices is distinguished from the others. A vertex of a rooted tree is called "node."

Your task is to write a program which reports the following information for each node u of a given rooted tree T:

  • node ID of u
  • parent of u
  • depth of u
  • node type (root, internal node or leaf)
  • a list of chidlren of u

If the last edge on the path from the root r of a tree T to a node x is (px), then p is the parent of x, and x is a child of p. The root is the only node in T with no parent.

A node with no children is an external node or leaf. A nonleaf node is an internal node

The number of children of a node x in a rooted tree T is called the degree of x.

The length of the path from the root r to a node x is the depth of x in T.

Here, the given tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Fig. 2 shows an example of rooted trees where ID of each node is indicated by a number in a circle (node). The example corresponds to the first sample input.

 
Fig. 2

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node u is given in the following format:

id k c1 c2 ... ck

where id is the node ID of uk is the degree of uc1 ... ck are node IDs of 1st, ... kth child of u. If the node does not have a child, the k is 0.

Output

Print the information of each node in the following format ordered by IDs:

node id: parent = p , depth = dtype, [c1...ck]

p is ID of its parent. If the node does not have a parent, print -1.

d is depth of the node.

type is a type of nodes represented by a string (root, internal node or leaf). If the root can be considered as a leaf or an internal node, print root.

c1...ck is the list of children as a ordered tree.

Please follow the format presented in a sample output below.

Constraints

  • 1 ≤ n ≤ 100000

Sample Input 1

13
0 3 1 4 10
1 2 2 3
2 0
3 0
4 3 5 6 7
5 0
6 0
7 2 8 9
8 0
9 0
10 2 11 12
11 0
12 0

Sample Output 1

node 0: parent = -1, depth = 0, root, [1, 4, 10]
node 1: parent = 0, depth = 1, internal node, [2, 3]
node 2: parent = 1, depth = 2, leaf, []
node 3: parent = 1, depth = 2, leaf, []
node 4: parent = 0, depth = 1, internal node, [5, 6, 7]
node 5: parent = 4, depth = 2, leaf, []
node 6: parent = 4, depth = 2, leaf, []
node 7: parent = 4, depth = 2, internal node, [8, 9]
node 8: parent = 7, depth = 3, leaf, []
node 9: parent = 7, depth = 3, leaf, []
node 10: parent = 0, depth = 1, internal node, [11, 12]
node 11: parent = 10, depth = 2, leaf, []
node 12: parent = 10, depth = 2, leaf, []

Sample Input 2

4
1 3 3 2 0
0 0
3 0
2 0

Sample Output 2

node 0: parent = 1, depth = 1, leaf, []
node 1: parent = -1, depth = 0, root, [3, 2, 0]
node 2: parent = 1, depth = 1, leaf, []
node 3: parent = 1, depth = 1, leaf, []

Note

You can use a left-child, right-sibling representation to implement a tree which has the following data:

  • the parent of u
  • the leftmost child of u
  • the immediate right sibling of u

Reference

Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.

题目链接:

https://vjudge.net/problem/Aizu-ALDS1_7_A

题目大意:给你一个有根树的各个信息,输出它的父亲,深度,是什么性质的节点,子节点列表

输入0 - N-1节点的度和子节点(无序), 要求按照节点序号输出节点的相关信息
node id: parent = p , depth = d, type, [c1…ck] 

具体做法都在代码上

AC代码

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>
#include <sstream>
#define mod 1000000007
#define eps 1e-6
#define ll long long
#define INF 0x3f3f3f3f
#define ME0(x) memset(x,0,sizeof(x))
using namespace std;
struct node
{
    int parent;
    int left,right;//左子右兄弟表示法,l代表节点u的最左侧的子结点,r为u的右侧紧邻的兄弟节点
};
node a[100005];
int D[100005];
void getDepth(int u,int p)//递归求结点的深度
{
    D[u]=p;
    if(a[u].right!=-1)//当前结点存在右侧兄弟节点,不改变深度
        getDepth(a[u].right,p);
    if(a[u].left!=-1)//存在最左侧子结点,深度+1
        getDepth(a[u].left,p+1);
}
void print(int u)
{
    cout<<"node "<<u<<": parent = "<<a[u].parent<<", depth = "<<D[u]<<", ";
    if(a[u].parent==-1)//不存在父结点,即为根节点
        cout<<"root, [";
    else if(a[u].left==-1)//没有子结点,即为叶
        cout<<"leaf, [";
    else
        cout<<"internal node, [";
    for(int i=0,c=a[u].left; c!=-1; ++i,c=a[c].right)
    {
        if(i)
            cout<<", ";
        cout<<c;//节点u的子结点列表从u的左侧子结点开始按顺序输出,直到当前子结点不存在右侧兄弟节点为止
    }
    cout<<"]"<<endl;

}
int main()
{
    int n;
    cin>>n;
    for(int i=0; i<n; ++i)//初始化
        a[i].left=a[i].parent=a[i].right=-1;
    for(int i=0; i<n; ++i)
    {
        int id,k;
        cin>>id>>k;
        for(int j=0; j<k; ++j)
        {
            int c,l;
            cin>>c;
            if(j)
                a[l].right=c;
            else
                a[id].left=c;
            l=c;
            a[c].parent=id;
        }
    }
    int root;//根节点的编号
    for(int i=0; i<n; ++i)
        if(a[i].parent==-1)
            root=i;
    getDepth(root,0);
    for(int i=0; i<n; ++i)
        print(i);
}

 

posted on 2019-06-23 22:03  Sky丨Star  阅读(394)  评论(0编辑  收藏  举报

导航