【UVA - 156 】Ananagrams (set,map,vector)

Ananagrams

 Descriptions:

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon
Input

题目链接:

https://vjudge.net/problem/UVA-156

 题意:输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本的另外一个单词。在判断是否满足条件时,字母不分大小写,但在输出时应保留输入中的大小写,按字典序进行排序。

因为不知道有多少个单词,就先用vector存起来,先全部转小写,按照字典顺序进行排序,然后用map存放这些处理过的单词,记录每个单词有多少个,然后数量为1的就是我们要找的单词,因为不重复且按照字典顺序,那么set是肯定要用的,存放最终答案,最后遍历set即可。

AC代码

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>
#include <sstream>
#define mod 1000000007
#define ll long long
#define INF 0x3f3f3f3f
#define ME0(x) memset(x,0,sizeof(x))
using namespace std;
map<string,int>words;//存放处理后的单词
vector<string> v;//存放初始单词
string s;
string stand(string r)//转小写,按照字典顺序排序
{
    string ans=r;
    int len=ans.length();
    for(int i=0;i<len;i++)
        ans[i]=towlower(ans[i]);
    sort(ans.begin(),ans.end());
    return ans;
}
int main()
{
    while(cin>>s,s!="#")
    {
        v.push_back(s);
        string r=stand(s);
        if(!words.count(r))//查询是否存在过
            words[r]=0;
        words[r]++;//这个单词出现一次加一次
    }
    set<string> ans;
    set<string>::iterator it;
    for(int i=0; i<v.size(); i++)
    {
        if(words[stand(v[i])]==1)//出现一次的存入set,就是最后答案
            ans.insert(v[i]);
    }
    for(it=ans.begin();it!=ans.end();it++)//遍历set,输出
        cout<<*it<<endl;
}

 

posted on 2019-06-08 21:16  Sky丨Star  阅读(365)  评论(0编辑  收藏  举报

导航