[结题报告]10346 - Peter's Smokes Time limit: 3.000 seconds

Problem B

Peter’s Smokes

Input: standard input

Output: standard output

Time Limit: 4 seconds

Memory Limit: 32 MB

 

Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.

How many cigarettes can Peter have?

Input

Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k. The input is terminated by end of file.

Output

For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

Sample Input

4 3
10 3
100 5

Sample Output

5
14
124

参考代码:
这道题有点像小学奥数瓶子换水,我的思路是将烟作为一个变量,烟头作为另一个变量,然后通过换率,计算出能换的数目。
#include"stdio.h"
main()
{  long n,k,s,m;    //n为烟,m为烟头,k为换率,s为总数 
   while(scanf("%ld%ld",&n,&k)!=EOF)
   {s=0;
    s+=n;
    m=n;
    while(m>=k)
    {n=m/k;
     s+=n;
     m=m%k+n;
     } 
     printf("%ld\n",s);
     }
}

 

posted @ 2013-02-17 11:42  天际。  阅读(339)  评论(0编辑  收藏  举报