题目: https://pintia.cn/problem-sets/1268384564738605056/problems/1274008636207132674

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
 

Sample Output:

3 4 2 6 5 1


题解: https://blog.csdn.net/zhang35/article/details/107359559
代码:

#include <iostream>
#include <vector>
#include <stack>
using namespace std;

vector<int> pre;
vector<int> in;
vector<int> post;

//已知pre、in,求post
//root为根在pre中的下标, left、right为in中的左右边界
void Post(int root, int left, int right){
    if (left > right) return;
    //定位in数组中根的位置,存储到i中
    int i = left;
    while(i<right && in[i]!=pre[root]) i++;
    Post(root+1, left, i-1);
    Post(root+1+i-left, i+1, right);
    post.push_back(pre[root]);
}

int main(){
    int n;
    cin >> n;

    stack<int> ss;

    string cmd;
    for (int i=0; i<2*n; i++){
        int k;
        cin >> cmd;
        if (cmd=="Push"){
            cin >> k;
            ss.push(k);
            pre.push_back(k);
        }
        else{
            in.push_back(ss.top());
            ss.pop();
        }
    }

    Post(0, 0, n-1);
    
    cout << post[0];
    for (int i=1; i<n; i++){
        cout << " " << post[i];
    }
    return 0;
}

 

 posted on 2020-09-05 21:58  邢涌芝  阅读(115)  评论(0编辑  收藏  举报