loongnix-server编译安装libtelnet

在loongnix-server8.3下编译guacamole-server时会使用到libtelnet ,但源里默认没有安装libtelnet ,因此需要编译安装一下:

1、源码获取

wget https://github.com/seanmiddleditch/libtelnet/archive/refs/tags/0.23.tar.gz
tar -zxvf 0.23.tar.gz 
cd libtelnet-0.23/

2、编译安装

./autogen.sh   //执行此生成config文件
./configure 
make
make install

编译完成后,文件默认在/usr/local/bin/下

posted @ 2023-02-22 10:51  silent  阅读(113)  评论(0编辑  收藏  举报