loongnix-server上编译安装libssh2

在loongnix-server8.3下编译guacamole-server时会使用到libssh2 ,但源里默认没有安装libssh2 ,因此需要编译安装一下:

1、代码获取:

wget https://gitcode.net/mirrors/libssh2/libssh2/-/archive/libssh2-1.10.0/libssh2-libssh2-1.10.0.tar.gz
tar -zxvf libssh2-libssh2-1.10.0.tar.gz 
cd libssh2-libssh2-1.10.0/

2、编译安装

autoreconf -fi
./configure
make
make install

可以在config中配置安装的路径等信息,默认安装后包在/usr/local/lib/libssh2.so 下

 

posted @ 2023-02-22 10:23  silent  阅读(96)  评论(0编辑  收藏  举报