龙芯平台安装docker-compose(loongnix-server)

1、首先安装docker

关闭防火墙:
systemctl stop firewalld
systemctl disable firewalld

安装docker
yum install docker-ce -y
service docker start
systemctl enable docker
验证一下
docker --version

2、安装jdk

yum install java-1.8.0-openjdk-devel
java --version

3、安装python3

yum install python36   --默认已经安装 
python3 --version 
yum install python3-devel 
yum install python3-pip  --默认已经安装
pip3 --version 
python3
-m pip install --upgrade --force pip

4、安装基础类库

yum install gcc libffi-devel openssl-devel -y
yum install rust -y

5、安装docker-compose

pip install docker-compose
执行成功后,可执行性文件默认保存在/usr/local/bin下
验证一下:
docker-compose --version
当前版本是1.29.2

常见问题为某些包未正常安装,可以通过

pip show XXXX 看有没有安装

常见问题1:安装cryptography报错

ERROR: Could not build wheels for cryptography, which is required to install pyproject.toml-based projects

 解决办法:

pip install cryptography==2.8  //版本号看报错日志指定

常见问题2:安装bcrypt报错

ERROR: Could not build wheels for bcrypt, which is required to install pyproject.toml-based projects

解决办法:

pip install bcrypt==3.1.3  //版本号看报错日志指定

常见问题3:安装pynacl报错

ERROR: Could not build wheels for pynacl, which is required to install pyproject.toml-based projects

解决办法:

pip install pynacl==1.5.0  //版本号看报错日志指定
如果安装失败,可以拷贝一份包到python3.6pip目录
一般地址为/usr/local/lib64/python3.6/site-package/下
附件中保存了包的地址

 

附件地址pynacl:下载

posted @ 2023-01-10 17:29  silent  阅读(1296)  评论(1编辑  收藏  举报