Try Again

ZOJ QS Network

QS Network

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

题意:在某个外星球有些叫QS的外星人。他们之间要相互联系。但是要买网络适配器,当然不同的QS喜欢不同价格的适配器。而且还需要买网络电缆,而且都需要费用。让你求用最小的花费去建立他们之间的联系。

 

//最小生成树
#include <iostream> 
#include <algorithm> 
#include <cstring> 
#include <cstdio>
#include <vector> 
#include <queue> 
#include <cstdlib> 
#include <iomanip>
#include <cmath> 
#include <ctime> 
#include <map> 
#include <set> 
using namespace std; 
#define lowbit(x) (x&(-x)) 
#define max(x,y) (x>y?x:y) 
#define min(x,y) (x<y?x:y) 
#define MAX 100000000000000000 
#define MOD 1000000007
#define pi acos(-1.0) 
#define ei exp(1) 
#define PI 3.141592653589793238462
#define ios() ios::sync_with_stdio(false)
#define INF 0x3f3f3f3f 
#define mem(a) (memset(a,0,sizeof(a))) 
typedef long long ll;
int g[1150][1150];
int vis[1150],n,t;
int val[1150];
int dis[1150],x,y;
int prime()
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=g[1][i];
        vis[i]=0;
    }
    vis[0]=1;
    int v,minn,sum=0;
    for(int i=1;i<=n;i++)
    {
        minn=INF;v=0;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && minn>dis[j])
            {
                v=j;
                minn=dis[j];
            }
        }
        vis[v]=1;
        if(minn!=INF) sum+=minn;
        else return sum;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]) dis[j]=min(dis[j],g[v][j]);
        }
    }
    return sum;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&g[i][j]);
                if(i!=j)g[i][j]+=val[i]+val[j];
            }
        }
        printf("%d\n",prime());
    }
    return 0;
}

 

 

 

 

posted @ 2017-08-02 10:21  十年换你一句好久不见  阅读(204)  评论(0编辑  收藏  举报