PTA 1165 Block Reversing (25 分)

1165 Block Reversing (25 分)

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
5
) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

感悟

不难的一道结构体排序题,但是又卡了一个点,经典的PTA单链表有无用结点.结构体用大括号整体赋值的时候,按顺序赋值,未赋值元素值为0,这个BUG卡了有20分钟.

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100010;

typedef pair<int, int> PII;

struct Node {
    int address;
    int data;
    int next;
    PII x;

    bool operator < (const Node& w) const {
        return x < w.x;
    }

}a[N];

int main()
{
    int start, n, k;
    scanf("%d%d%d", &start, &n, &k);
    for(int i = 0 ; i < N ; i ++) a[i].x = {N,N};
    for (int i = 0; i < n; i++)
    {
        int address,data,next;
        scanf("%d%d%d", &address, &data, &next);
        a[address] = {address, data, next, {N, N}};
    }
    int cnt = 0;
    for (int i = start,j = 0; i != -1; i = a[i].next, j ++, j %= k, cnt ++)
        a[i].x = {n/k - cnt/k,j};
    sort(a,a + N);         
    // 会有不在链表里的结点
    for(int i = 0 ; i < cnt ; i ++)
    {
        if(i != cnt - 1) printf("%05d %d %05d\n",a[i].address,a[i].data,a[i+1].address);
        else printf("%05d %d -1\n",a[i].address,a[i].data);
    }
        return 0;
}
posted @ 2022-02-22 16:46  别问了我什么都不会  阅读(74)  评论(0编辑  收藏  举报