PTA 1162 Postfix Expression (25 分)

1162 Postfix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding postfix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG
Figure 1 Figure 2
Output Specification:
For each case, print in a line the postfix expression, with parentheses reflecting the precedences of the operators.There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(((a)(b)+)((c)(-(d))*)*)

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(((a)(2.35)*)(-((str)(871)%))+)

感悟

这题说难也不难,但是有个点半天过不去.+和-都是作为一元运算符的时候是要提前面的,开始只考虑了负号,看了别人的题解才明白.
当这个节点只有右儿子的时候那他就是一元运算符.一棵算法树的节点是不会出现只有左儿子没有右儿子的情况.要么两个儿子都有,就是一个二元操作符,要么只有右儿子节点,就是一个一元操作符.
还是考虑不周.

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 30;
int tree[N];

struct Node
{
    string data;
    int l,r;
}node[N];

string getstring(int x)
{
    string s;
    if(node[x].l == -1 && node[x].r == -1)
    {
        s+="(";
        s+=node[x].data;
        s+=")";
        return s;
    }
    else 
    {
        s += "(";
        int flag = 1;
        if(!(node[x].l != -1 && node[x].r != -1)) s += node[x].data,flag = 0;
        if(node[x].l != -1) s += getstring(node[x].l);
        if(node[x].r != -1) s += getstring(node[x].r);
        if(flag) s += node[x].data;
        s += ")";
        return s;
    }
}

int main()
{
    int n;
    cin >> n;
    for(int i = 1 ; i <= n; i++)
    {
        cin >> node[i].data >> node[i].l >> node[i].r;
        if(node[i].l != -1) tree[node[i].l] = i;
        if(node[i].r != -1) tree[node[i].r] = i;
    }
    int idx = 1;
    while(tree[idx] != 0) idx++;

    cout << getstring(idx) << endl;

    return 0;
}
posted @ 2022-02-13 00:34  别问了我什么都不会  阅读(80)  评论(0编辑  收藏  举报