PTA 1161 Merging Linked Lists (25 分)

1161 Merging Linked Lists (25 分)

Given two singly linked lists L1 = a1 → a2​ → ⋯ →an-1​ →a n and L2 =b 1 → b2→ ⋯ → bm-1 → bm.If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1 → a 2 → bm → a3​ → a4 →bm-1 ⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2 , plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 105
, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

感悟

这题写的蛮糙的,花里胡哨的写完了,没啥难点,就是要注意题目里没说哪里个地址是长链表的首地址,哪个是短链表的首地址,所以就需要判断一下哪个链表长哪个链表短,然后拼一下完事
顺便试一下markdown里面两种上下角标的实现,用html5的话上角标是sup标签下角标是用sub标签.它们都是双标签,后面要用</ >结尾.markdown下角标是用两个~,上角标是用两个^.

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100010, INF = 0x3f3f3f3f;

struct Node 
{
    int address,data,next;
    int id;
    bool operator < (const Node &w)const
    {
        return id<w.id;
    }
}a[N];

void getid(int address)
{
    if(a[address].next == -1) a[address].id = 3;
    else 
    {
        getid(a[address].next);
        a[address].id = a[a[address].next].id+3;
    }
}

int main()
{
    int start1,start2,n;
    scanf("%d%d%d", &start1, &start2, &n);
    for(int i = 0 ; i < n; i ++)
    {
        int address,data,next;
        scanf("%d%d%d", &address, &data, &next);
        a[address] = {address,data,next};
    }
    int cnt = 0;
    for(int i = start1; i != -1 ;i = a[i].next)cnt++;
    if(n-cnt>cnt)swap(start1,start2);
    for(int i = 0 ; i <  N ; i ++) a[i].id = INF;
    for(int i = start1, j = 1 ; i != -1 ;i = a[i].next, j ++)
    {
        if(j%3 == 0) j ++;
        a[i].id = j;
    }
    getid(start2);
    sort(a,a+N);
    for(int i = 0 ; i < N ; i++)
    {
        if(a[i].id == INF) break;
        if(a[i+1].id == INF) printf("%05d %d -1\n",a[i].address,a[i].data);
        else printf("%05d %d %05d\n",a[i].address,a[i].data,a[i+1].address);
    }
    
    return 0;
}

posted @ 2022-02-12 23:10  别问了我什么都不会  阅读(119)  评论(0编辑  收藏  举报