TOJ-1203 Factoring Large Numbers

One of the central idea behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.

You don't have those computers available, but if you are clever you can still factor fairly large numbers.


Input

The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's long long int datatype.


Output

Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number, and followed by a single blank line.


Sample Input

90
1234567891
18991325453139
12745267386521023
-1


Sample Output

    2
    3
    3
    5

    1234567891

    3
    3
    13
    179
    271
    1381
    2423

    30971
    411522630413



Source: Waterloo Local Contest Sep. 28, 1996

分解因式。

#include <stdio.h>  
int main(){  
    long long i,n;  
    while(~scanf("%lld",&n) && n>=0){ 
        for(i=2 ; n>1 ;){  
            if(n%i == 0){  
                printf("    %lld\n",i);  
                n/=i;  
            }  
            else{  
                i++;  
                if(i*i>n){  
                    printf("    %lld\n",n);  
                    break;  
                }  
            }  
        }  
        printf("\n");  
    }  
    return 0;  
}  

 

posted @ 2017-01-19 12:37  DGSX  阅读(145)  评论(0编辑  收藏  举报