hdu5411 CRB and Puzzle[矩阵优化dp]

 

CRB and Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1177    Accepted Submission(s): 468


Problem Description
CRB is now playing Jigsaw Puzzle.
There are N kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most M pieces? (Two patterns P and Q are considered different if their lengths are different or there exists an integer j such that j-th piece of P is different from corresponding piece of Q.)
 

 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers N, M denoting the number of kinds of pieces and the maximum number of moves.
Then N lines follow. i-th line is described as following format.
a_{1}\ a_{2}\ ...\ a_{k}
Here k is the number of kinds which can be assembled to the right of the i-th kind. Next k integers represent each of them.
1 ≤ T ≤ 20
1 ≤ N ≤ 50
1 ≤ M ≤ 10^5
0 ≤ k ≤ N
1 ≤ a_{1} < a_{2} < … < a_{k} ≤ N

 

 

Output
For each test case, output a single integer - number of different patterns modulo 2015.
 

 

Sample Input
1 3 2 1 2 1 3 0
 

 

Sample Output
6
Hint
possible patterns are ∅, 1, 2, 3, 1→2, 2→3
 

 

Author
KUT(DPRK)
 

 

Source
 

 

Recommend
wange2014

 

同样的题:不同的写法,却得不出相同的答案。poj3233 Matrix Power Series

望大佬给蒟蒻答疑

 Select Code

#include<cstdio>
#include<cstring>
using namespace std;
const int mod=2015;
struct matrix{
	int s[102][102];
	matrix(){
		memset(s,0,sizeof s);
	}
}A,F;int n,m,T;int ans;
matrix operator *(const matrix &a,const matrix &b){
	matrix c;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			for(int k=0;k<n;k++){
				c.s[i][j]+=a.s[i][k]*b.s[k][j];
			}
			c.s[i][j]%=mod;
		}
	}
	return c;
}
matrix fpow(matrix a,int p){
	matrix res;
	for(int i=0;i<n;i++) res.s[i][i]=1;
	for(;p;p>>=1,a=a*a) if(p&1) res=res*a;
	return res;
}
int main(){
	for(scanf("%d",&T);T--;){
		scanf("%d%d",&n,&m);
		matrix A;
		for(int i=0,k,x;i<n;i++){
			scanf("%d",&k);
			while(k--){
				scanf("%d",&x);x--;
				A.s[i][x]=1;
			}
		}
		for(int i=0;i<n;i++) A.s[i][i+n]=A.s[i+n][i+n]=1;
		n<<=1;
		A=fpow(A,m);
		n>>=1;
		ans=1;
		for(int i=0;i<n;i++){
        	for(int j=n;j<2*n;j++){
        		ans+=A.s[i][j];
			}
		}
		ans%=mod;
		printf("%d\n",ans);
	}
	return 0;
}
posted @ 2017-04-18 10:48  神犇(shenben)  阅读(340)  评论(0编辑  收藏  举报