poj2421

Constructing Roads
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22048   Accepted: 9389

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

题解

有n个村庄,编号为1 ,2 ,3 ,,,n  应该建造道路使他们互相可达

对输入数据

3
0 990 692
990 0 179
692 179 0
1
1 2

意思有3个村庄,

0 990 692
990 0 179
692 179 0

意思是1号到1,2,3的距离分别为0 990 692

1
1 2

意思是有一条道路已经接通,就是1号与2号间的道路

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 110
struct node{
    int x,y,v;
}e[N*(N+1)];
int n,m,k,tot,cnt,fa[N];
bool cmp(const node &a,const node &b){
    return a.v<b.v;
}
int find(int x){
    return fa[x]==x?x:fa[x]=find(fa[x]);
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++) fa[i]=i;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            int x;
            scanf("%d",&x);
            if(x){
                e[++cnt].x=i;e[cnt].y=j;e[cnt].v=x;
            }
        }
    }
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        int fx=find(x),fy=find(y);
        if(fx!=fy) fa[fy]=fx;
    }
    sort(e+1,e+cnt+1,cmp);
    for(int i=1;i<=cnt;i++){
        int fx=find(e[i].x),fy=find(e[i].y);
        if(fx!=fy){
            fa[fy]=fx;
            tot+=e[i].v;
            k++;
        }
        //if(k==n-m-1) break;不能这样写(并查集原理理解错了) 
        if(k==n-1) break;//是mst,这里就不能改 
    }
    printf("%d\n",tot);
    return 0;
}

 

posted @ 2016-06-30 16:19  神犇(shenben)  阅读(489)  评论(0编辑  收藏  举报