【原创】poj ----- 3009 curling 2 解题报告

题目地址:

http://poj.org/problem?id=3009

 

题目内容:

Curling 2.0
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13042   Accepted: 5478

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

 
 
 
解决方法:
 
首先英语阅读要过关。
0、只能往上下左右4个方向运动
1、如果碰到石头,就停在石头旁边的格子,同时石头被砸烂。
2、不能往紧挨着石头的方向运动。
3、如果没有石头就飞出棋盘,然后算输。
4、如果经过了终点,就算赢。
5、必须在10步内解决。
 
了解了规则以后,可以发现,由于最多可以有10步,每步最多有4个选择,所以暴搜的复杂度是4^10,完全可以用DFS + 回溯解决。
 
需要注意不要弄混行列。
 
 
具体代码:
 
#include <stdio.h>
#define ROCK 1
#define GOAL 3
int map[30][30];
int w,h;


int dfsfind(int startx, int starty, int finx, int finy, int deep)
{
  if (deep > 10)
    return -1;
  int min = 11;
  
  //往左边移动
  if (startx > 0 && map[startx - 1][starty] != ROCK) {
    int tmpx = startx;
    while (tmpx > 0 && map[tmpx - 1][starty] != ROCK) {
      if (map[tmpx - 1][starty] == GOAL) {
    return 1;
      }
      tmpx --;
    }
    //若有石头
    if (tmpx != 0) {
      
      int rockx = tmpx - 1;
      int rocky = starty;
      map[rockx][rocky] = 0;
      int tmpmin = dfsfind(tmpx, starty, finx, finy, deep + 1) + 1;
      map[rockx][rocky] = ROCK;
      if (tmpmin > 0 && min > tmpmin) {
    min = tmpmin;
      }
    }
  }
  
  //往右边移动
  if (startx < h - 1 && map[startx + 1][starty] != ROCK) {
    int tmpx = startx;
    while (tmpx < h - 1 && map[tmpx + 1][starty] != ROCK) {
      if (map[tmpx + 1][starty] == GOAL) {
    return 1;
      }
      tmpx ++;
    }
    //若有石头
    if (tmpx != h - 1) {
      int rockx = tmpx + 1;
      int rocky = starty;
      map[rockx][rocky] = 0;
      int tmpmin = dfsfind(tmpx, starty, finx, finy, deep + 1) + 1;
      map[rockx][rocky] = ROCK;
      if (tmpmin > 0 && min > tmpmin) {
    min = tmpmin;
      }
    }
  }

  //往上方移动
  if (starty > 0 && map[startx][starty - 1] != ROCK) {
    int tmpy = starty;
    while (tmpy > 0 && map[startx][tmpy - 1] != ROCK) {
      if (map[startx][tmpy - 1] == GOAL) {
    return 1;
      }
      tmpy --;
    }
    //若有石头
    if (tmpy != 0) {
      int rockx = startx;
      int rocky = tmpy - 1;
      map[rockx][rocky] = 0;
      int tmpmin = dfsfind(startx, tmpy, finx, finy, deep + 1) + 1;
      map[rockx][rocky] = ROCK;
      if (tmpmin > 0 && min > tmpmin) {
    min = tmpmin;
      }
    }
  }

  //往下移动
  if (starty < w - 1 && map[startx][starty + 1] != ROCK) {
    int tmpy = starty;
    while (tmpy < w - 1 && map[startx][tmpy + 1] != ROCK) {
      if (map[startx][tmpy + 1] == GOAL) {
    return 1;
      }
      tmpy ++;
    }
    //若有石头
    if (tmpy != w - 1) {
      int rockx = startx;
      int rocky = tmpy + 1;
      map[rockx][rocky] = 0;
      int tmpmin = dfsfind(startx, tmpy, finx, finy, deep + 1) + 1;
      map[rockx][rocky] = ROCK;
      if (tmpmin > 0 && min > tmpmin) {
    min = tmpmin;
      }
    }
  }
  return min < 11 ? min : -1;
}

int main(void)
{
  int startx,starty;
  int finx,finy;
  while (scanf("%d%d", &w, &h)) {
    if (w == 0 && h == 0)
      break;
    for (int i = 0; i < h; i ++) {
      for (int j = 0; j < w; j ++) {
    scanf("%d", &map[i][j]);
    if (map[i][j] == 2) {
      startx = i;
      starty = j;
    } else if (map[i][j] == 3) {
      finx = i;
      finy = j;
    }
      }
    }
    int res = dfsfind(startx, starty, finx, finy, 0);
    printf("%d\n", res);
  }
  
  return 0;
}

 

posted on 2015-03-18 00:28  shadowmydx'sLab  阅读(274)  评论(0编辑  收藏  举报

导航