Win7 x64bit安装Oracle10g

解决方案:

 

步骤一:在解压出的oracle文件夹中搜索refhost.xml文件,搜索结果出现2条符合条件文件,这两个文件均需要修改.

 

打开文件发现内容中有包含...5.0 6.0等系统说明,在其中添加

 

<OPERATING_SYSTEM>

<VERSION VALUE="6.1"/>

</OPERATING_SYSTEM>

注:两个文件均需添加

 

 

步骤二:在安装文件夹根目录内进入install文件夹,编辑oraparam.ini文件,找到[Certified Versions]位置,在其下

 

 

#You can customise error message shown for failure, provide value for CERTIFIED_VERSION_FAILURE_MESSAGE

Windows=5.0,5.1,5.2,6.0,6.1

 

中添加6.1,并在接下来各版本定义中添加:

 

[Windows-6.1-required]

#Minimum display colours for OUI to run

MIN_DISPLAY_COLORS=256

#Minimum CPU speed required for OUI

#CPU=300

[Windows-6.1-optional]

 

步骤三:再次点击setup.exe安装成功!

 

 

 

 

 

 

===================================================================================================================================

 

 

 

 

 

 

工具网上的资料改了refhost.xml文件 添加了

<!--Microsoft Windows 7-->

<OPERATING_SYSTEM>

<VERSION VALUE="6.1"/>

</OPERATING_SYSTEM>

后来用xp sp3 兼容模式,管理员运行安装,

刚装完 Oracle 10g,然后,进行em后,界面出来了,但报了一个错:

java.lang.Exception: Exception in sending Request :: null

很多功能不能用,提示重新登录

 

解决方案:找到下面的文件

$ORACLE_HOME\db_1\$HOSTNAME\sysman\config\emd.properties

其中的agentTZRegion缺省是GMT,改为你所在的时区即可,例如:

agentTZRegion=Asia/Chungking

关于时区的列表参考:10.2.0\db_1\sysman\admin\supportedtzs.lst

然后先停止 dbconsole 使时区设置生效并重启OracleDBConsole:

然后先停止dbconsole 在重启dbconsole :

set ORACLE_SID=orcl

 

emctl stop dbconsole

 

emctl start dbconsole

 

 

 

=========================================================================================================================

 

 

 

安装好win7后,下载JDK,配置环境变量,安装MyEclipse8、安装MySQL、配置Tomcat6一路下来没有任何问题,就是安装Oracle10G出现了问题。win7与oracle 10G不兼容,但是教学必须要用10G所以还是放弃了安装11G的念头。具体安装过程如下:

 

 

 

将oralce 10G的安装镜像解压都硬盘,找到\stage\prereq\db\ 下的refhost.xml文件添加如下内容:

 

<!--Microsoft Windows 7-->

<OPERATING_SYSTEM>

<VERSION VALUE="6.1"/>

</OPERATING_SYSTEM>

 

 

再到install目录中找到oraparam.ini文件,添加如下内容:

[Windows-6.1-required]

#Minimum display colours for OUI to run

MIN_DISPLAY_COLORS=256

#Minimum CPU speed required for OUI

#CPU=300

[Windows-6.1-optional]

 

 

 

之后点击steup.exe进行安装,此时选择高级选项,自定义安装还是有问题,所以无奈只有用默认配置,一路下来,安装成功。

通过手工执行以下命令:

创建一个EM资料库

emca -repos create

重建一个EM资料库

emca -repos recreate

删除一个EM资料库

emca -repos drop

配置数据库的 Database Control

emca -config dbcontrol db

删除数据库的 Database Control配置

emca -deconfig dbcontrol db

重新配置db control的端口,默认端口在1158

emca -reconfig ports

emca -reconfig ports -dbcontrol_http_port 1160

emca -reconfig ports -agent_port 3940

先设置ORACLE_SID环境变量后,启动EM console服务

emctl start dbconsole

先设置ORACLE_SID环境变量后,停止EM console服务

emctl stop dbconsole

先设置ORACLE_SID环境变量后,查看EM console服务的状态

emctl status dbconsole

 

经查询,此问题是由于enterprise manager database control组件的跟CA证书授权过期造成的,其证书到期日为2010年12月31日,2011年安装此版本数据库都会出现这个问题,官方的解决方案是打Patch 8350262

 

单实例数据库应用此patch的方法如下:

 

1、安装或者升级数据库到10.2.0.4过程中忽略此错误继续安装,数据库的创建不受影响。

2、使用opatch把此补丁应用到oracle安装

设置ORACLE_HOME和ORACLE_SID系统环境变量,将%ORACLE_HOME%\opatch加入PATH环境变量,将patch 8350262解压缩,打开cmd窗口,进入解压缩后目录,执行

cmd>opatch apply

完成后检查%ORACLE_HOME%\cfgtoollogs\opatch\目录下生成的日志文件确认安装patch是否成功。

3、应用patch成功后,重新配置em dbconsole

cmd>emctl secure dbconsole -reset

根据提示输入管理员密码,然后会有两次确认请求,两次都是输入大写的Y

4、重新启动dbconsole

cmd>emctl start dbconsole

 

当然,如果不使用enterprise manager database control这个组件的话,那么可以不用理会这个错误,不打这个patch。

posted @ 2015-09-20 22:56  SBaiCL  阅读(190)  评论(0编辑  收藏