Vue项目按需打包Lodash

使用的是 webpack 模板

1. 首先安装

npm install lodash --save
npm install lodash-webpack-plugin babel-plugin-lodash --save-dev

第二行的部分插件 webpack 模板已经默认安装

 

2. 修改 .babelrc

plugins 中添加 lodash,我的项目添加完如下:

  "plugins": ["transform-vue-jsx", "transform-runtime", "lodash"]

 

3. 修改 webpack.prod.config.js

由于我只需要打包时体积小即可,所以添加到这个配置文件中

const LodashModuleReplacementPlugin = require('lodash-webpack-plugin')

  // 省略
  plugins: [
    new LodashModuleReplacementPlugin(),
    // 你的其他配置
  ]

 

 

 

参考:

webpack-lodash插件官方文档

webpack按需加载lodash

 

posted @ 2018-03-06 16:03 savokiss 阅读(...) 评论(...) 编辑 收藏