ANE-调用原生地图注意点

打包的bat

bin/adt -package  -target ane test.ane extension.xml -swc AneTest.swc -platform iPhone-ARM -C iPhone-ARM -platformoptions platformoptions.xml . -platform default -C default .

注意-platformoptions platformoptions.xml的位置。

 


platformoptions.xml内容

<platform xmlns="http://ns.adobe.com/air/extension/3.7">
    <sdkVersion>5.0.0</sdkVersion>
    <linkerOptions>
        <option>-ios_version_min 5.0</option>
        <option>-framework MapKit</option>
    </linkerOptions>
</platform>

注意sdkVersion与-ios_version_min的值与xmlns的版本号


最后是extension.xml的内容

<extension xmlns="http://ns.adobe.com/air/extension/3.7"> 
    <id>net.digitalprimates.volume</id> 
    <versionNumber>0.0.1</versionNumber> 
    <platforms> 
        <platform name="iPhone-ARM"> 
            <applicationDeployment> 
                <nativeLibrary>libVolumeAne.a</nativeLibrary> 
                <initializer>VolumeExtensionInitializer</initializer>
                <finalizer>ExtFinalizer</finalizer>
            </applicationDeployment>
        </platform>
        <platform name="default"> 
            <applicationDeployment/> 
        </platform>
    </platforms> 
</extension>


注意xmlns的版本号

posted on 2014-07-26 14:17 老镇 阅读(...) 评论(...) 编辑 收藏

导航

公告