代码改变世界

hdu 1695 gcd

2016-04-17 13:05  koujiao的蒻苣  阅读(193)  评论(0编辑  收藏  举报

容斥原理:

所有不与x互素的数的个数= 1个因子倍数的个数 - 2个因子乘积的倍数的个数 + 3个……-……

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8901    Accepted Submission(s): 3289


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
 

Sample Output
Case 1: 9
Case 2: 736427

Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

  给你一个正整数N,确定在1到N之间有多少个可以表示成M^K(K>1)的数。

打表60以内的素数,然后容斥

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;
int list[]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59};
long long ans,n;
int i;

void dfs(int mid,int num,int k){
    if(k==0){
        long long temp=pow(n,1.0/num);      
        if(pow(temp,0.0+num)>n)  temp--;
        temp--;
        if(temp>0)
            ans+=temp*(i&1?1:-1);          //!!
        return ;
    }
    if(mid>=17)
        return ;
    if(num*list[mid]<60)  
        dfs(mid+1,num*list[mid],k-1);
    dfs(mid+1,num,k);
}
int main(){
    while(scanf("%I64d",&n)!=EOF){
        ans=0;
        for(i=1;i<=3;i++)
            dfs(0,1,i);
        printf("%I64d\n",ans+1);
    }
    return 0;

}