hdu 1394 Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20446    Accepted Submission(s): 12266


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

 

Output
For each case, output the minimum inversion number on a single line.
 

 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

 

Sample Output
16
 

 

Author
CHEN, Gaoli
 

 

Source
 
 
题目说是一个环
那么每转一次,就相当于把第一个数放到最后面
考虑第一个数对原有答案的贡献是a[1]-1,也就是小于它的个数(数据是1到n的排列)
最后一个数对原答案的贡献相反
那么移动后当前逆序对数就要减去比第一个数小的个数,再加上比它大的数的个数
这样我们求出一次移动后的逆序对数
这时候我们发现下一次移动直接修改答案就好
推出式子ans+=n-a[i]-(a[i]-1) 
代码是自己写的 。
#include <algorithm>
#include <cstdio>
#define N 5500
using namespace std;
struct node
{
    int mid,l,r,dis;
    node *left,*right;
    node()
    {
        left=right=NULL;
        mid=0;dis=0;
    }
}*root;
int data[N],a[N],n;
void build(node *&k,int l,int r)
{
    k=new node;
    k->l=l;k->r=r;
    k->mid=(l+r)>>1;
    if(l==r) {k->dis=0;return ;}
    build(k->left,l,k->mid);
    build(k->right,k->mid+1,r);
}
void change(node *&k,int t)
{
    if(k->l==k->r) {k->dis++;return;}
    if(k->mid>=t) change(k->left,t);
    else change(k->right,t);
    k->dis=k->left->dis+k->right->dis;
}
int query(node *&k,int l,int r)
{
    if(k->l==l&&k->r==r) return k->dis;
    if(l>k->mid) return query(k->right,l,r);
    else if(r<=k->mid) return query(k->left,l,r);
    else return query(k->left,l,k->mid)+query(k->right,k->mid+1,r);
}
int main()
{
    for(;scanf("%d",&n)!=EOF;)
    {
        root=new node;
        build(root,0,n);
        int ans,sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            ans=sum+=query(root,a[i]+1,n);
            change(root,a[i]);
        }
        for(int i=0;i<n;i++)
        {
            sum+=n-a[i]-a[i]-1;
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2017-07-19 07:49  杀猪状元  阅读(165)  评论(0编辑  收藏  举报