POJ 1998 Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

农民约翰和Betsy N玩游戏(1≤N≤30000)相同的方块标记1通过他们从N堆,每个都包含一个单一的立方体。农民John asks Betsy执行P(1≤P = 100000)操作。有两种类型的操作:
动作和计数。
*在移动操作,农民John asks Bessie搬上含含立方体堆栈堆栈立方体X Y
*计数操作,农民John asks Bessie数的多维数据集的数目与立方体,立方体的X X报告值下的堆栈。
编写一个程序,可以验证游戏的结果。
输入
*行1:一个整数,P
*行2 P + 1:每一行描述了一个合法的操作。第2行描述了第一个操作,每一行以一个“M”开头,用于移动操作或“C”用于计数操作.。对于移动操作,该行还包含两个整数:x和y用于计数操作,该行还包含一个整数:x。
注意,n值不会出现在输入文件中.。没有移动操作将请求移动堆栈本身。
输出
按输入文件相同的顺序打印来自每个计数操作的输出.。

带权并查集 

#include<cstdio>
#define N 30001

int count[N], num[N], pre[N];

int find(int x)
{
    if(pre[x] == x)
    return x;
    int t = find(pre[x]);
    count[x] += count[pre[x]];
    pre[x] = t;
    return t;
}
void Union(int x, int y)
{
    int i = find(x);
    int j = find(y);
    if(i == j)
    {
        return;
    }
    count[i] = num[j];
    num[j] += num[i];
    pre[i] = j;
}
int main()
{
    int i, x, y, n;
    char s[2];
    scanf("%d",&n);
    for(i = 1; i <= N; i++)
    {
        pre[i] = i;
        num[i] = 1;
        count[i] = 0;
    }
    for(i = 0; i < n; i++)
    {
        scanf("%s",s);
        if(s[0] == 'M')
        {
            scanf("%d%d",&x,&y);
            Union(x,y);
        }
        else if(s[0] == 'C')
        {
            scanf("%d",&x);
            int c = find(x);
            printf("%d\n",count[x]);
        }
    }
    return 0;
}

 

posted @ 2017-01-17 16:24  杀猪状元  阅读(233)  评论(0编辑  收藏  举报