poj 3159 Candies 差分约束

Candies
Time Limit: 1500MS   Memory Limit: 131072K
Total Submissions: 22177   Accepted: 5936

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid Bshould never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source


        先输入n,m

        接下来m行,每行输入A,B,C

        输入A B C,表示孩子B最多比孩子A多C块蛋糕,问孩子1与孩子N最多相差多少块蛋糕!

Tips:

                不能用queue<>队列来做,模拟队列可以!



#include "stdio.h"
#include "string.h"
//#include "queue"
//using namespace std;

#define N 30005  //图中点的个数
#define INF 0x3fffffff

struct node
{
    int x,y;
    int weight;
    int next;
}edge[5*N];

int n,m;
int dist[N];
bool mark[N];
int head[N],idx;
int stack[5*N];

void Init();
void SPFA();
void Add(int x,int y,int k);

int main()
{
    int i;
    int x,y,k;
    scanf("%d %d",&n,&m);
        Init();
        for(i=0; i<m; ++i)
        {
            scanf("%d %d %d",&x,&y,&k); /***y-x<=k***从点x到点y建边,权值为k**/
            Add(x,y,k);
        }
        SPFA();
        printf("%d\n",dist[n]);
    return 0;
}

void Init()
{
    idx = 0;
    memset(head,-1,sizeof(head));
}

void Add(int x,int y,int k)
{
    edge[idx].x = x;
    edge[idx].y = y;
    edge[idx].weight = k;
    edge[idx].next = head[x];
    head[x] = idx++;
}

void SPFA()  //这题只能模拟队列~
{
    int i;
    int x,y;
    memset(mark,false,sizeof(mark));
    for(i=1; i<=n; ++i)  dist[i] = INF;
    int top = 0;
    //queue<int> q;
    stack[++top] = 1;//q.push(1);
    mark[1] = true;
    dist[1] = 0;
    while(top)
    {
        x = stack[top--];
        //q.pop();
        for(i=head[x]; i!=-1; i=edge[i].next)
        {
            y = edge[i].y;
            if(dist[y] > dist[x] + edge[i].weight)
            {
                dist[y] = dist[x] + edge[i].weight;
                if(!mark[y])
                {
                    mark[y] = true;
                    stack[++top] = y;//q.push(y);
                }
            }
        }
        mark[x] = false;
    }
}


posted @ 2014-04-23 18:44  ruo_yu  阅读(196)  评论(0编辑  收藏  举报