riverphoenix

导航

 

摘要: 今天在工作的时候发现自己update 一个表的某个字段超时,想了好久,首先想到的办法是,延长操作时间:mysql> set innodb_lock_wait_timeout=100mysql> show variables like 'innodb_lock_wait_timeout'; 但是时间... 阅读全文
posted @ 2014-06-18 16:41 riverphoenix 阅读(755) 评论(0) 推荐(0)
 

摘要: 程序猿小菜一枚,最近从github上面下载下来一份spring各个项目的源码一份,但是弄了很长时间,因为网速和(fanqiang)的速度,希望大家不要再为这种无谓的时间花费时间,简单来说github上面是源代码,但是想要编译或者导入进eclipse或者myeclipse 就要重新下载工程文件,然后用gradle编译,但是编译的前提是你安装了openjdk1.8.所以我提供给大家的源码包括了源码+项目文件+编译失败的东西(如果不想看见那么多错误),只要删除文件夹下面的build文件夹,有时间的话可以拿到linux下重新编译。下载地址是http://pan.baidu.com/s/1h7i7w,欢 阅读全文
posted @ 2013-11-12 22:38 riverphoenix 阅读(394) 评论(0) 推荐(0)
 

摘要: 13毕业生,刚刚入职没多久,前两个月一直在各种培训,最近才开始做项目(与前期培训基本无关),公司现在有自己的一套类库和开发工具,开发不过是前台拖控件,后台调用封装好的公司自己的SSH的API(就是在上面多封装了一层),但是项目经理对于我的表现并不满意,而且我发现自己虽然做过web项目但是对于这种集成化程度这么高的类库,还是有点无从下手的感觉。博客园藏龙卧虎希望大家能多给我一点建议,谢谢 阅读全文
posted @ 2013-09-16 22:47 riverphoenix 阅读(410) 评论(0) 推荐(0)
 

摘要: (define (expmod base exp m ) (cond ((=exp 0 ) 1) ((even? exp) (remainder (square (expmod base (/ exp 2) m)) m)) (else (remainder (* base (expmod base (- exp 1) m)) m)) ))(define (fermat-test n) (define (try-it a) (= (expmod a n n) a)) (try-it (+1 (random (- n 1)))))(define (fast-prime? n times) (c.. 阅读全文
posted @ 2012-03-05 22:36 riverphoenix 阅读(226) 评论(0) 推荐(0)
 

2014年7月31日

摘要: 在DB2中的Date 一共识别三种格式,最常见的是这样'2013-12-12' 对,你没看错,DB2认为这样的字符串就是Date数据然后我们可以利用函数这样寻找日期区间select * from users where g_time between '2003-05-04 ' and '2003-... 阅读全文
posted @ 2014-07-31 19:43 riverphoenix 阅读(12771) 评论(0) 推荐(0)
 

2013年11月13日

摘要: (define (sum a b) (+ a b))(define (sum-two a b c) ( cond ((and (> (sum a b) (sum a c)) (> (sum a b) (sum b c))) (sum a b)) ((and (> (sum a c) (sum a b)) (> (sum a c) (sum b c))) (sum a c)) (else (sum b c)) ))(sum-two 1 2 3) 阅读全文
posted @ 2013-11-13 23:27 riverphoenix 阅读(138) 评论(0) 推荐(0)
 

2013年9月4日

摘要: Dos下连接mysql后,运行一下几项就可以插入中文了:SET character_set_client = gbk; SET character_set_connection = gbk; SET character_set_database = gbk; SET character_set_results = gbk; SET character_set_server = gbk;SET collation_connection = gbk_bin; SET collation_database = gbk_bin; SET collation_server = gbk_bin; 阅读全文
posted @ 2013-09-04 10:15 riverphoenix 阅读(211) 评论(0) 推荐(0)
 

2013年8月26日

摘要: 今天想用jdbc做个小程序,结果发现好久不用的mysql不好用了,我装的是社区版(win7)环境下,按理说不可能出问题,找了一堆解决方案都没解决,准备重装的时候想把mysql服务停了,直接在dos输入services,弹出服务窗,看见mysql下面还有一个mysql55的服务,点击,启动,问题解决了,真是无语,竟然有两个服务。 阅读全文
posted @ 2013-08-26 12:53 riverphoenix 阅读(508) 评论(0) 推荐(0)
 

2013年7月30日

摘要: 由于新装的系统没有安装网卡驱动,各大厂商的标准又不一样,有的电脑在linux下不用安装无线网卡驱动,而很不幸,我的电脑是ret的网卡,只能自行安装,在安装无线网卡的过程中使用到了chkconfig的命令,直接导致 file exists错误,找了半天教程,找到以下解决方法:#chkconfig --level 35 network on #chkconfig --level 0123456 NetworkManager off #service NetworkManager stop //如果没有开启万恶的NM的话,这步可能会失败,不过不重要。 #service network stop #s 阅读全文
posted @ 2013-07-30 08:57 riverphoenix 阅读(563) 评论(0) 推荐(0)
 

2013年7月20日

摘要: 1. 确定自己的网卡和内核版本:lspci | grep Network #根据输出的信息确定网卡的型号。uname -a #确定内核版本2. 配置yum使用RPMForgeyum install yum-priorities3. 编辑 /etc/yum/pluginconf.d/priorities.conf确保其中含有下面的内容:[main]enable=14. 编辑/etc/yum.repos.d/下的.repo files对每个repository条目设置priority=N,推荐的设置如下:[base], [addons], [updates], [extras] ... prior 阅读全文
posted @ 2013-07-20 11:50 riverphoenix 阅读(1606) 评论(0) 推荐(0)
 

2013年7月7日

摘要: 安装:解压后即可用。目录下的start_navicat文件为可执行文件。 破解:(找过好几个注册码都不能用,注册码生成器都是Windows平台的,Linux下不行) ----第一次执行start_navicat时,会在用户主目录下生成一个名为.navicat的隐藏文件夹。 ----此文件夹下有一个system.reg文件 ----把此文件删除后,下次启动navicat 会重新生成此文件,30天试用期会按新的时间开始计算。 ----将就着用了 阅读全文
posted @ 2013-07-07 20:02 riverphoenix 阅读(320) 评论(0) 推荐(0)