hdu4722 Good Numbers

Good Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 45 Accepted Submission(s): 14

Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

 

Sample Input
2 1 10 1 20
 

 

Sample Output
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 

 

Source
 

 

Recommend
zhuyuanchen520
找规律题,水题!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
__int64 ff(__int64 m)
{
    if(m<0)
    return 0;
    __int64 temp=m/100,ans;
    __int64 i;
    ans=temp*10;
    for(i=temp*100;i<=m;i++)
    {
       __int64 sum=0,t=i;
       while(t)
       {
           sum+=t%10;
           t/=10;
       }
      if(sum%10==0)
      ans++;
    }
    return ans;
}
int main()
{
    int tcase ,tt=1;
    __int64 a,b;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%I64d%I64d",&a,&b);
        printf("Case #%d: %I64d\n",tt++,ff(b)-ff(a-1));
    }
    return 0;
}


 

posted on 2013-09-11 21:00  you Richer  阅读(200)  评论(0编辑  收藏  举报