hdu2817之整数快速幂

 

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2033    Accepted Submission(s): 627

Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

 

Sample Input
2 1 2 3 5 1 2 4 5
 

 

Sample Output
5 16
 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10;
const int mod=200907;

__int64 pow(__int64 a,__int64 k){
	__int64 sum=1;
	while(k){
		if(k&1)sum=(sum*a)%mod;
		a=(a*a)%mod;
		k>>=1;
	}
	return sum;
}

int main(){
	__int64 n,a,b,c,k;
	cin>>n;
	while(n--){
		cin>>a>>b>>c>>k;
		if(b-a+b == c)printf("%I64d\n",((k-1)%mod*((b-a)%mod)+a%mod)%mod);
		else{
			__int64 q=b/a;
			printf("%I64d\n",(pow(q,k-1)*(a%mod))%mod);
		}
	}
	return 0;
} 

 

posted on 2013-08-05 20:13  you Richer  阅读(166)  评论(0编辑  收藏  举报