hdu 1018

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40597    Accepted Submission(s): 19843


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

 

Sample Input
2 10 20
 

 

Sample Output
7 19
 

 

Source
题目意思:
给你一个数字,让你求出它的阶乘的位数。
一般的做法肯定想的是阶乘起来然后求位数,但是这个数字如果特别大的话,肯定就没办法了,那这个时候该怎么办呢?
我们需要先知道一个知识:一个数的位数=log10(a)+1;
好的
接下来让我们推导一下(此部分摘自别人的博客):
对于任意一个给定的正整数a,假设10^(x-1)<=a<10^x,那么显然a的位数为x位,
  又因为
  log10(10^(x-1))<=log10(a)<(log10(10^x))
  即x-1<=log10(a)<x
  则(int)log10(a)=x-1,
  即(int)log10(a)+1=x
  即a的位数是(int)log10(a)+1

我们知道了一个正整数a的位数等于(int)log10(a) + 1,
现在来求n的阶乘的位数:
假设A=n!=1*2*3*......*n,那么我们要求的就是
(int)log10(A)+1,而:
log10(A)
        =log10(1*2*3*......n)  (根据log10(a*b) = log10(a) + log10(b)有)
         =log10(1)+log10(2)+log10(3)+......+log10(n)
现在我们终于找到方法,问题解决了,我们将求n的阶乘的位
数分解成了求n个数对10取对数的和,并且对于其中任意一个数,
都在正常的数字范围之类。
(评论:真实巧妙......)
以下为ac代码:

#include<stdio.h>
#include<math.h>
typedef long long ll;
int main()
{

int n;
scanf("%d",&n);
while(n--)
{
ll a,i;
double s=0;
scanf("%lld",&a);
for(i=1;i<=a;i++)
{
s+=log10(i);
}
printf("%d\n",(int)s+1);

 

}

 

 


return 0;
}

 

 

posted @ 2018-02-07 22:06  zero1998  阅读(74)  评论(0编辑  收藏  举报