Sightseeing Cows(POJ 3126)【01分数规划】

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00

我们不需要管它到底怎么走,我们要关注的是它最大的乐趣数

推导公式:

ans = S到达的景点乐趣 / S所走的路程  

· 变形为:

ans * S所走的路程 = S到达的景点乐趣

· 移项:

ans * S所走的路程 - S到达的景点乐趣 = 0

设 f(x) = x * S所走的路程 - S到达的景点乐趣 = 0

 

我们通过二分ans , 判断:

f(x) < 0 ,说明 x 枚举的偏小,增大范围

f(x) > 0 ,说明 x 枚举的偏大,缩小范围

 

· 注意要设一个"du",习惯性精度多开10-2

code

#include<stdio.h> 
#include<algorithm> 
using namespace std;
const int MX=10010;
struct Edge {
    int to,next,val;
}edge[MX];
int a[MX];
double w[MX],dis[MX];
int n,m,cnt,first[MX];
bool vis[MX];
void add(int from,int to,int val) 
{
    edge[++cnt].to=to;
    edge[cnt].next=first[from];
    edge[cnt].val=val;
    first[from]=cnt;
}

bool spfa(int x) 
{
    vis[x]=1;
    for(int i=first[x];i;i=edge[i].next) 
    {
        int to=edge[i].to;
        if(dis[x]+w[i]<dis[to]) {
            dis[to]=dis[x]+w[i];
            if(vis[to] || spfa(to)) {
                vis[x]=0;
                return 1;
            }
        }
    }
    return vis[x]=0;
}

bool check(double x) {
    for(int i=1;i<=cnt;++i) {
        int to=edge[i].to;
        w[i]=(double)x*edge[i].val-a[to];
    }
    for(int i=1;i<=n;++i) {
        if(spfa(i)) return 1;
    }
    return 0;
} 

int main() 
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;++i) {
        scanf("%d",&a[i]);
    }
    for(int i=1;i<=m;++i) {
        int from,to,val;
        scanf("%d%d%d",&from,&to,&val);
        add(from,to,val);
    }
    double l=0,r=1e6,du=1e-6;
    while(r-l>du) {
        double mid=(l+r)/2;
        if(check(mid)) l=mid;
        else r=mid;
    }
    printf("%.2lf",l);
    return 0;
}

 

posted @ 2018-10-12 16:20  qseer  阅读(160)  评论(0编辑  收藏  举报