poj 1088 滑雪 记忆化搜索

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 79919   Accepted: 29747

Description

Michael 喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个 区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5

16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25
题解:跑一发DFS,记忆化搜索一下就好
#include<iostream>
using namespace std;
int dir[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
int n,m;
int map[102][102];
int dp[102][102];
int dfs(int x,int y)
{
    //cout <<x << " " << y << endl;
    int tx,ty,i;
    if(dp[x][y])                         //当已经搜索过时就返回
        return dp[x][y];
    for(i =  0;i < 4;i++)
    {
        tx = x + dir[i][0] , ty = y + dir[i][1];
        if(tx >= 0 && tx < n && ty >= 0 && ty < m && map[tx][ty] < map[x][y])//搜索+ 状态转移方程
        {
            int temp = dfs(tx,ty); //递归的出口有两个1.在11行;2.在16行
            if(dp[x][y] <= temp) //i=0时比较dfs(x+1, y);i=1时比较dfs(x, y+1);i=2时比较dfs(x-1, y);i=3时比较dfs(x, y-1)
            {   
                dp[x][y] = temp+1;    
            }
        }
    }
    return dp[x][y];
}
int main()
{
    int i,j,t;
    while(cin >> n >> m)
    {
        for(i =0 ;i < n;i++)
        {
            for(j = 0;j < m;j++)
            {
                cin >> map[i][j];
                dp[i][j] = 0;
            }
        }
        int max = -1;
        for(i = 0 ;i < n;i++)
        {
            for(j = 0;j < m;j++)
            {
                t = dfs(i,j);
                if(max < t)
                {
                    max = t;
                }
            }
        }
        cout <<max + 1 << endl;
    }
    return 0;
}

 

posted @ 2015-03-05 13:53  qscqesze  阅读(608)  评论(0编辑  收藏  举报