poj 3250 Bad Hair Day(栈的运用)

http://poj.org/problem?id=3250

Bad Hair Day
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15985   Accepted: 5404

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题目大意:

n个数,从左到右排成一排,问每个数的右边比他小的数有几个,然后求和


可以反过来想,看每个数他的左边有多少个数比他大的有几个,然后再加起来

用栈来模拟,先将第一个数压入栈:

如果栈首元素S.top() > a[i],

则栈里面的元素都比a[i]大,那么比a[i]大的数的个数就是栈里面的元素个数S.size();

否则栈首元素S.top() <= a[i],说明S.top()不符合条件(不大于a[i])

则让栈首元素出栈,继续比较栈内元素如果不大于a[i],就让他出栈

也就是说栈内的元素都是比a[i]大的数


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<stack>
#include<algorithm>

using namespace std;
const int N = 80010;
typedef __int64 ll;

int a[N];

int main()
{
    stack<int>S;
    int n;
    while(~scanf("%d", &n))
    {
        ll sum = 0;
        for(int i = 0 ; i < n ; i++)
            scanf("%d", &a[i]);
        S.push(a[0]);//第一个数进栈
        for(int i = 1 ; i < n ; i++)//遍历
        {
            while(!S.empty() && S.top() <= a[i])
                S.pop();//出栈
            sum += S.size();
            S.push(a[i]);//入栈
        }
        printf("%I64d\n", sum);
    }
    return 0;
}

 





posted @ 2015-11-19 15:34  午夜阳光~  阅读(264)  评论(0编辑  收藏  举报