poj 2594 Treasure Exploration(最小路径覆盖+闭包传递)

http://poj.org/problem?id=2594

Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 7398   Accepted: 3025

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2


一开始看到这道题以为就是简单的最小路径问题,直接套用最模版提交了,没想到wa了,仔细一看发现自己把题想简单了,还是没有彻底理解概念
题中有句话还是蛮重要的(已经用红色标出来了),多个士兵可以经过相同的一个点

如:1->3,2->3,3->4,3->5, 如果用平常的最小路径来写顶点最多只经过一次,结果就是;而这道题顶点可以经过多次,结果应该是2,两个士
兵都可以经过点3

那么如何来构造普通最小路径的二分图呢

如果上例,1 和 2 都经过点3 分别到达 4 和 5 ,那么就让 1 和 2 不通过 点3 直接到达 4 和 5,用Floyd来构造二分图使之可以用普通的
最小路径覆盖来写


#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define N 510
#define INF 0x3f3f3f3f

using namespace std;

int G[N][N], vis[N], used[N];
int m, n;

bool Find(int u)
{
    int i;
    for(i = 1 ; i <= n ; i++)
    {
        if(!vis[i] && G[u][i])
        {
            vis[i] = 1;
            if(!used[i] || Find(used[i]))
            {
                used[i] = u;
                return true;
            }
        }
    }
    return false;
}

void Floyd()
{
    int i, j, k;
    for(k = 1 ; k <= n ; k++)
    {
        for(i = 1 ; i <= n ; i++)
        {
            for(j = 1 ; j <= n ; j++)
            {
                if(G[i][k] && G[k][j])
                    G[i][j] = 1;
            }
        }
    }
}//求传递闭包并构建新的二分图

int main()
{
    int i, a, b;
    while(scanf("%d%d", &n, &m), m + n)
    {
        memset(G, 0, sizeof(G));
        while(m--)
        {
            scanf("%d%d", &a, &b);
            G[a][b] = 1;
        }
        Floyd();
        memset(used, 0, sizeof(used));
        int ans = 0;
        for(i = 1 ; i <= n ; i++)
        {
            memset(vis, 0, sizeof(vis));
            if(Find(i))
                ans++;
        }
        printf("%d\n", n - ans);
    }
    return 0;
}

 




posted @ 2015-09-23 09:56  午夜阳光~  阅读(160)  评论(0编辑  收藏  举报